Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,684,403

members

50

online now

1,852,782

discussions

Back to Top

can't log into mail on any browser using Windows 10

Posted by
Frequent Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 1 of 5
173 Views

I am unable to log into Comcast mail using any browswer on a Dell laptop running  Windows 10....this problem occured within the last week.  I've tried IE 11 (get message that it's out of date), Firefox and Chrome....none of them work.  I get an authentication error.  However, on my desktop and phone I am having no problem.  Any suggestions?

4 REPLIES
Posted by
Email Expert

Message 2 of 5
135 Views

I have a Dell Inspiron Windows 10, and I'm not having this issue.  Are you running the most recent iterations of those browsers?  Have you tried clearing browsing history?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 3 of 5
127 Views

Yes.....and I just updated Chrome to the latest and it still won't work.   When I open Edge or IE to the Xfinity log in page, I also get a "Browser out of date" error which I cannot do anything about because I am running the latest versions of both browsers.  Is there some setting in the Registry that I can tweak that might take care of this and perhaps then I can log in?

Posted by
Frequent Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 4 of 5
120 Views

I've downloaded and installed some Dell updates for my laptop.....particularly for the Intel network and wireless cards.  After the reboot I was able to log into my Comcast mail using Chrome......I will check the other browsers after I have read my mail.  I was still getting a browser out of date issue with Edge.  But at least I can finally log in to get my mail and manage my Xfinity account.

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 5 of 5
93 Views

I still cannot access email using Edge or Explorer ...... I can access using Chrome ..... although I don't like Chrome, it is better than nothing.