Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,809,212

members

40

online now

1,954,800

discussions

Top

Unwanted names on account

Regular Visitor

Unwanted names on account

When people receive my e-mails, they are sometimes "sent by" one of two names that are not mine. I have looked into removing those names from my account, but do not find them listed. This is very confusing to people who may receive one of these e-mails that I sent but they received from another name. Can anyone help me?

 

Service Expert

Re: Unwanted names on account

From your Inbox choose Preferences-->Email-->Composing.  Check to see what Your name in e-mails will be is and change it to whatever you want.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark a Best Answer!solution Icon

Regular Visitor

Re: Unwanted names on account

Thank you for your guidance. I have changed my settings accordingly.

Gold Problem Solver

Re: Unwanted names on account

If they do not show in your Users in My Account at all, I would first change your password.  On the homepage scroll down to Quick Links, then click on Reset my password.

 

I would also call 1-800 Comvast and tell the Rep you are experiencing.



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.