Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,807,961

members

68

online now

1,953,831

discussions

Top

Unable to Send Outgoing Emails from iPhone (and now Laptop) via Comcast.net Account

ANSWERED
New Poster

Unable to Send Outgoing Emails from iPhone (and now Laptop) via Comcast.net Account

I have an iPhone 5, which I use to check my Comcast.net email regularly. For the past 2-3 months, I have been unable to sent OUTGOING emails via my phone. Emails come into my mailbox fine, but when I try to reply or compose a new message, an error message is displayed:

 

"Cannot Send Mail
The username or password for 'SMTPSmiley Sadmyemailaddress)@smtp.comcast.net' is incorrect."

 

I was fairly certain my password was entered correctly, but I reset my password anyway to ensure the correct information could be entered in. I created a new password for my account and entered it into my email settings for my phone. The problem persisted - emails are received fine, but I cannot send an OUTGOING email. Additionally, my password change has created the exact same problem now on my Laptop (MacBook Pro) - Emails are received but I cannot send anything out. I'm certain the usernames and passwords are entered correctly and am frustrated I cannot have full use of my email.

I am leaving for vacation tomorrow morning and really need to be able to send outgoing emails. Please advise on how we can correct this problem.

Thank you!

Accepted Solution

Re: Unable to Send Outgoing Emails from iPhone (and now Laptop) via Comcast.net Account

In iOS, you need to set the password in two places------for the incoming server, and then again for the outgoing smtp server. Did you do that? If not, to change it for the smtp server;


go to "Settings" on the home screen, then scroll down to" Mail, Contacts, Calendars", click on the account, and then on the next screen tap the "account" again. Scroll down to "SMTP" and tap that. Then tap "smtp.comcast.net". On the next screen you will see the password. Change it and then tap "Done" in the upper right hand corner of the screen.

 

And for OS X---------This is for Yosemite, but I think it should apply to newer versions too-------------

 

 

Changing Password for SMTP Server in Mail 8.2 (Yosemite)

 

Enabling (SMTP AUTH)

 

Open Mail.app.

Go to Mail > Preferences

Click Accounts > Account Information

Under Account Information look for Outgoing Mail Server (SMTP).

 

Click on the drop down arrow and select Edit Server List...

Select the existing SMTP server for your domain.

Click Advanced

 

From the Authentication drop down, select Password

Fill in your Username (e.g. john@example.com) and Password

 

Click the Test Account Settings button to set the new settings.

Click OK and then close the preferences window.

Click Next then Finish.

Save the changes, and try sending mail again

View answer in context
Email Expert

Re: Unable to Send Outgoing Emails from iPhone (and now Laptop) via Comcast.net Account

In iOS, you need to set the password in two places------for the incoming server, and then again for the outgoing smtp server. Did you do that? If not, to change it for the smtp server;


go to "Settings" on the home screen, then scroll down to" Mail, Contacts, Calendars", click on the account, and then on the next screen tap the "account" again. Scroll down to "SMTP" and tap that. Then tap "smtp.comcast.net". On the next screen you will see the password. Change it and then tap "Done" in the upper right hand corner of the screen.

 

And for OS X---------This is for Yosemite, but I think it should apply to newer versions too-------------

 

 

Changing Password for SMTP Server in Mail 8.2 (Yosemite)

 

Enabling (SMTP AUTH)

 

Open Mail.app.

Go to Mail > Preferences

Click Accounts > Account Information

Under Account Information look for Outgoing Mail Server (SMTP).

 

Click on the drop down arrow and select Edit Server List...

Select the existing SMTP server for your domain.

Click Advanced

 

From the Authentication drop down, select Password

Fill in your Username (e.g. john@example.com) and Password

 

Click the Test Account Settings button to set the new settings.

Click OK and then close the preferences window.

Click Next then Finish.

Save the changes, and try sending mail again




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: Unable to Send Outgoing Emails from iPhone (and now Laptop) via Comcast.net Account

That did the trick - thank you!