Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,808,947

members

13

online now

1,954,681

discussions

Top

Page constantly refreshes and drops me back to inbox after reading or deleting mail

Frequent Visitor

Page constantly refreshes and drops me back to inbox after reading or deleting mail

Why am I suddenly (past week or more) getting a "page refresh" after reading or deleting emails.  The page refresh always brings me back to the inbox which is frustrating when trying to delete emails via email search or from special folders since you have to re-enter the search or go back in to special folders to continue where you left off! It's taking me more than twice as long to do any email cleanup in comcast mail because of this.   

Contributor

Re: Page constantly refreshes and drops me back to inbox after reading or deleting ma


cdecde wrote:

Why am I suddenly (past week or more) getting a "page refresh" after reading or deleting emails.  The page refresh always brings me back to the inbox which is frustrating when trying to delete emails via email search or from special folders since you have to re-enter the search or go back in to special folders to continue where you left off! It's taking me more than twice as long to do any email cleanup in comcast mail because of this.   


Wow! I thought I was in the Twilight Zone when This same exct thing happened to me. It started the past week and a half or so till the present. I open an e-mail, then read it, then when I close the email, the whole page goes through a refresh. Ads and all, and takes a while to load some of the items. I thought it was because of using chrome, but it happens when using IE 10 also.

I have three comcast accounts. One primary account, and two secondary accounts.

All on Comcast Mail Client.... 

It is very annoying. I am running Windows 8 Operating system 32 bit. 

I deleted and cleared all the cookies and cashe. Still, it refreshes the whole page. 

 

The only thing is, I recieved a notice from Xfinity that said, "Now your internet service speed is faster....At no cost to you as a valued customer, speed has increased too mb?second from ?mb?second..... Now to think of it, It was at about the time that the notice of the increased speed, that the refresh page after reading mail had started. It ( the notice ) did say,"There is nothing you have to do!" This service is automatically installed on your systems modem!"

 

I don't know if that specifically had anything to do with the refresh problem, but it was the only thing that I thought may be causing the problem.