Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,805,567

members

5

online now

1,951,934

discussions

Top

Outgoing e-mail from my Apple 5s has problem with password for SMTP.COMCAST.NET

New Poster

Outgoing e-mail from my Apple 5s has problem with password for SMTP.COMCAST.NET

Outgoing e-mail from my Apple 5s has problem with password for SMTP.COMCAST.NET says it is incorrect - how can I reset it?

Customer Expert

Re: Outgoing e-mail from my Apple 5s has problem with password for SMTP.COMCAST.NET

These settings apply to all Apple products - iPhone, iPad, iPod Touch, Mac.


You need to set the username and password in two places - once for incoming and once for outgoing. The ports are different for incoming (995 to mail.comcast.net) and outgoing(465 to smtp.comcast.net). You need to turn on SSL and have password authentication. 


Screenshots showing needed information. Your screens may be slightly different but info is correct.

 

Get to the screen shown at bottom. Be sure to click Done. 

 

mailAcct.jpg     

 

 

 

 

 

 

 

mailSMTP.jpg   

 

 

mailOutgoing.jpg






Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: Outgoing e-mail from my Apple 5s has problem with password for SMTP.COMCAST.NET

Beth, thank you, it worked!