Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,807,854

members

14

online now

1,953,718

discussions

Top

OUTGOING MAIL DOES NOT WORK

Frequent Visitor

OUTGOING MAIL DOES NOT WORK

Up until three days ago, I was able to send mail from my mail client (apple mail) on my Macbook Pro. Suddenly, I get the message that the comcast server is offline. This has happened regularly before, but it has always come back online in a short period of time. Three days later, it still does not work. I've contacted Comcast customer service—the absolute worst on earth—and gotten no help. According to the young man who barely spoke English, there is something wrong with my computer.

 

If I had another option than Comcast, I'd switch yesterday...

 

Anyone have any ideas? The username and password are entered correctly and nothing else has changed. The port has been 995 ever since I set it up a few years ago.

Gold Problem Solver

Re: OUTGOING MAIL DOES NOT WORK


Artistwoman54 wrote:

Up until three days ago, I was able to send mail from my mail client (apple mail) on my Macbook Pro. Suddenly, I get the message that the comcast server is offline. This has happened regularly before, but it has always come back online in a short period of time. Three days later, it still does not work. I've contacted Comcast customer service—the absolute worst on earth—and gotten no help. According to the young man who barely spoke English, there is something wrong with my computer.

 

If I had another option than Comcast, I'd switch yesterday...

 

Anyone have any ideas? The username and password are entered correctly and nothing else has changed. The port has been 995 ever since I set it up a few years ago.


Your settings should be :

Incoming server: mail.comvast.net

Port 995 for INCOMING email with SSL. ON

Your Out going server should be SMTP.Comcast.net

Port should be  bp 465 with SSL. ON

This server requires AUTHENTICATIIN under thecServer  tab must be checked,

Do not check SOA ( secure password AUTHENTICATIIN)

 



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Frequent Visitor

Re: OUTGOING MAIL DOES NOT WORK

The settings are exactly the same as they have been all along, the same as you have indicated. It just quit working. Transferring everything to Gmail, which works all the time. Not worth the headaches.

Email Expert

Re: OUTGOING MAIL DOES NOT WORK

In Mail, you have to set the password in two places.  Did you do that?  If not it will generate a "ID or password is incorrect" error.  If that is the case, here are the instructions for setting it in the smtp server--------------(I am using Yosemite)

 

 

 

Enabling (SMTP AUTH)

 

Open Mail.app.

Go to Mail > Preferences

Click Accounts > Account Information

Under Account Information look for Outgoing Mail Server (SMTP).

Click on the drop down arrow and select Edit Server List...

Select the existing SMTP server for your domain.

Click Advanced

From the Authentication drop down, select Password

Fill in your Username (e.g. john@example.com) and Password

Click the Test Account Settings button to set the new settings.

Click OK and then close the preferences window.

Click Next then Finish.

Save the changes, and try sending mail again

 

 

 




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Frequent Visitor

Re: OUTGOING MAIL DOES NOT WORK

Still doesn't work for outgoing mail. Settings and password are correct. Now what?

Frequent Visitor

Re: OUTGOING MAIL DOES NOT WORK

"The connection to the server “smtp.comcast.net” on port 995 timed out.

Select a different outgoing mail server from the list below or click Try Later to leave the message in your Outbox until it can be sent."

Contributor

Re: OUTGOING MAIL DOES NOT WORK

Are you using POP3 or IMAP?

Frequent Visitor

Re: OUTGOING MAIL DOES NOT WORK

POP3

Gold Problem Solver

Re: OUTGOING MAIL DOES NOT WORK


Artistwoman54 wrote: "The connection to the server “smtp.comcast.net” on port 995 timed out. ...

SMTP operates using port 465 or 587. Port 995 is for POP, not SMTP. Either the server name or the port number is incorrect. See http://customer.xfinity.com/help-and-support/internet/email-client-programs-with-xfinity-email/.

Frequent Visitor

Re: OUTGOING MAIL DOES NOT WORK

In the dialog box, the server is correct. The user name and password is correct. The "use default ports (25, 465, 587) radio button is checked. Use SSL is checked. This mail client worked perfectly (for the most part) until Friday, and suddenly would no longer send mail. NOTHING had changed. I have followed every suggestion, but nothing seems to make a difference, as the outgoing server (smtp.comcast.net) is still offline.

 

I give up.

Contributor

Re: OUTGOING MAIL DOES NOT WORK


Artistwoman54 wrote:

"The connection to the server “smtp.comcast.net” on port 995 timed out.

Select a different outgoing mail server from the list below or click Try Later to leave the message in your Outbox until it can be sent."


Artistwoman, I understand the frustation, but, the error message you have there directly contradicts what is supposed to be configured for your mail client.

 

There are *two* server names

 

POP3 server name:  mail.comcast.net

 

SMTP server name: smtp.comcast.net

 

 

The POP3 server uses port 995 to *receive* email from the server to your pc.

 

SMTP uses port 465 (or 587 some times) to send email out to the server and on to the net.

 

Your error, if copied correctly, clearly indicates that the configuration of your email client has somehow messed up, because it tells you "smtp.comcast.net on port 995 timed out" ... SMTP should **ONLY** show up if going out to port 465 or port 587, *not* 995.

 

While you may not have directly edited the configuration, were there any updates applied to your machine or applications?  If so maybe one of those updates messed up the config, it has happened before.

 

Please carefully check the boxes, make sure the correct names are where they are supposed to be, and the correct ports, as well as SSL & TLS settings *SPECIFIC* to those two servers.

 

-T

Frequent Visitor

Re: OUTGOING MAIL DOES NOT WORK

I make my living on the computer. I've worked with Apple mail since it was first released, so I do know how to set up the mail client. I have made no upgrades or changes. It just simply quit working. I am well aware that port 995 is the incoming mail port, and that is why I was so confused when I got that message, because it had been set to 465.

 

I have checked and rechecked everything, and nothing works. I am receiving mail on my other accounts, but not on the comcast account. That's something new, too. This is too frustrating to keep screwing around with. Comcast is of no help, and everyone here has been very gracious with their time and suggestions.

 

Thank you, all.

Email Expert

Re: OUTGOING MAIL DOES NOT WORK

I use Apple Mail, and I'm running Yosemite on an iMac.  When I first got the machine 6 1/2 years ago, Mail developed an issue------------about every 3 months or so it would delete all my email in all the inboxes I had set up in it.  I was able to restore everything because I use Time machine with an external hard drive.  So nothing was lost, but it was annoying to have to keep doing this as you can well imagine.  So for a long time I used Thunderbird instead.  Then when I later updated to Mountain Lion I started using Mail again and haven't had any major issues with it since.  I have 4 Comcast accounts running in mail right now, one of which is POP3.

 

Suggestion------------set the account up in Thunderbird and see if it works OK for you.  If so, then at least you will have narrowed it down to something going on with Mac Mail and not your account.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Frequent Visitor

Re: OUTGOING MAIL DOES NOT WORK

OK, so I tried the comcast account in Thunderbird and it works. However, I cannot import any of the other accounts from Apple mail. Apparently there is another entire process to go through so that Apple mail accounts can be imported in another mail client.

 

I am considering deleting the comcast account and adding it back...but at this point, I'm afraid I won't be able to even get my mail...

 

Any thoughts? I really do appreciate everyone's suggestions. And if anyone knows of an easy way to import the apple mail to my gmail account (once again, Apple had made it a PITA) please enlighten me.

 

Thanks, everyone.

b

Frequent Visitor

Re: OUTGOING MAIL DOES NOT WORK

OK, I just added a Comcast imap account (previously was pop), deleted the old one, and voilá, I can now send mail (until the next time it flakes out).

 

All of your help has been appreciated. I feel kinda dumb that I didn't just do that before...<sigh>

b