Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,679,451

members

75

online now

1,848,549

discussions

Back to Top

New Xfinity Webmail

Posted by
Email Expert

Message 251 of 512
3,026 Views

Those icons are becoming standard fare with more and more email providers.  They are aimed more at the mobile users.  Similar icons are used by iCloud, Ourlook.com and other providers.  At some point, all Comcast customers will be migrated to the new format.  you cannot revert to the old one.  If you don't like the new one, consider enabling the account in a desktop email client like Thunderbird, Windows Live Mail or some other.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 252 of 512
3,017 Views
Okay, I can't delete emails. I can't move beyond the first screen. The list of actions screen slides up and covers the emails no matter what action I take. It is utterly impossible. If I try to check an email in order to delete it I'm told I haven't selected an item. Sometimes when I try to check an email it won't check. In short, my email is entirely dysfunctional. I can't even get the system to open an email when I click on it. This is a freaking disaster. I'm on an iPhone and whatever you did you ruined it royally.
Posted by
Frequent Visitor

Message 253 of 512
3,013 Views

Latoque wrote:

Those icons are becoming standard fare with more and more email providers.  They are aimed more at the mobile users.  Similar icons are used by iCloud, Ourlook.com and other providers.  At some point, all Comcast customers will be migrated to the new format.  you cannot revert to the old one.  If you don't like the new one, consider enabling the account in a desktop email client like Thunderbird, Windows Live Mail or some other.


Two points I'd like to address about the above...

 

#1- If so many of us paying customers are having such problems with this new email system comcast has forced down our throats, then there is no reason they "can't" revert back to the previous system which was a very easy to use and FUNCTIONAL system which did not give so many problems, nor was down as much as this new one. It's that they "wont" because they don't care what their customers think.

 

#2- The whole reason for this new emails system when they forced it on us was (and I quote Comcast here) "To make for an easier and better email experience". Yet your suggestion to those of us having issues is to enable our accounts in a email clint like Thunderbird or Windows live. Hardly seems like an easier or better system when the best option is to switch to a new client don't ya think??

 

I've seriously gone so far past my patience limit with comcast that I can't wait to get everything comcast related out of my house and be done with this horrible company for good.

Posted by
Email Expert

Message 254 of 512
2,998 Views

Raderwoman wrote:
Okay, I can't delete emails. I can't move beyond the first screen. The list of actions screen slides up and covers the emails no matter what action I take. It is utterly impossible. If I try to check an email in order to delete it I'm told I haven't selected an item. Sometimes when I try to check an email it won't check. In short, my email is entirely dysfunctional. I can't even get the system to open an email when I click on it. This is a freaking disaster. I'm on an iPhone and whatever you did you ruined it royally.

I have an iPhone, and have not had any issues with my Comcast email on it.  I'm using the Mail app that comes bundled in iOS.  Delete the account from the phone and re-create it from scratch.  See if that solves the problem.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
New Poster
  • Congrats on Posting your first topic!

Message 255 of 512
2,970 Views

Whoever thought this upgrade and new look was a good idea was wrong.  This is awful.  What was the purpose of the change?  Just to change?  The first thing I have to do is to space a few times to get my signature from the top of the email.  

 

Please just leave things alone.  

Posted by
Email Expert

Message 256 of 512
2,904 Views
Posted by
Contributor

Message 257 of 512
2,885 Views

     My dial-up  email loads faster than this.  I haven't had the patience to use this yet  This is better?

Posted by
Contributor

Message 258 of 512
2,871 Views

    Interesting that since my last post immediately above  the internet connection got very very spotty.

Posted by
New Poster
Message 259 of 512
2,820 Views

Just to add diversity to the thread - this is what I see both in Firefox and Chrome after the email upgrade. Cannot get to folders, cannot compose messages, cannot see any old messages.

 

Posted by
Regular Contributor

Message 260 of 512
2,746 Views

I'm OK with the new look and happy to see a receipt option is now provided.  However, the inbox loads MUCH more slowly than the old version did.  I watch three dancing dots on the screen until the mailbox finally appears.  I'm not against progress, but slowing down performance is a step in the wrong direction.  Smiley Sad

Posted by
Email Expert

Message 261 of 512
2,741 Views


Try clearing out your browser's cache/browsing history. When you have done that, close out the browser and re-start it in a fresh session.

If that doesn't do it, then try using a different browser and see if you can duplicate the problem that way.  I haven't had any issue with loading speed myself.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 262 of 512
2,722 Views

I totally detest this new format. Advise how to get back to way it was. that is what i want otherwise i will switch. i have lost emails that are very very important.

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 263 of 512
2,722 Views

I too have lost emails just by glancing. I must have them back very important that I need. 

Posted by
Email Expert

Message 264 of 512
2,713 Views

bet5 wrote:

I totally detest this new format. Advise how to get back to way it was. that is what i want otherwise i will switch. i have lost emails that are very very important.


Once you have been migrated to the new format, you cannot revert to the old one.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Contributor

Message 265 of 512
2,684 Views

New e-mail is a total joke.  Mail is all about words & text, not symbols that, by the way are not universal.  Loading of new messages and processing once in the in-box is taking 2-3 times longer than the previous version.  This is progress?

Just got another surprise......my new Address book as double-entered or triple-entered every address!!!  Any suggestions on a quick way to fix this problem (now have several thousand entries)?

BVR

Posted by
Frequent Visitor

Message 266 of 512
2,646 Views

I don't know why, but my email appeared in a new format a week or so ago.

Seems like every other time I open mail something is different.   Like all folder are there - or maybe only a fourth of them. 

Sometimes all of my eamail is there - about a hundred, including a few a year old.  Other times all is normal. 

Seems like Ive become a beta tester.

 

I read that a new email format will be available to selected people around April 2017 for evaluation. 

Please don't include me on that change.  Seems to me, I'm already on it.   My wife's eamail has not

changed.

 

Ron

Posted by
Regular Contributor

Message 267 of 512
2,635 Views

Please DO include me on the next version. Or roll me back to the previous. The current version with the black banner is unacceptable.  I've cleared the cache and tried different browsers, but is is SLOW,  unbelievably SLOW.   

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 268 of 512
2,622 Views

It is so slow I get errors and session timeouts and I am on Xtreme Internet...which aint  so extreme but that is for another post. My email is completely inaccessible since 9PM last night. I have an emeil to verify an account change and cannot access Webmail at all. The new system stinks!

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 269 of 512
2,620 Views

For example here are my screens

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 270 of 512
2,618 Views

Well now I can access email, but my entire history from 9PM yesterday and back are completely gone!

Posted by
New Poster
Message 271 of 512
2,596 Views

The new Comcast/Xfinity email is really bad.  It crashes frequently, loads images sent as attachments much more slowly than before, and it is harder to use.  

Posted by
New Poster
Message 272 of 512
2,588 Views

Now getting this error message.  

 

502 Bad Gateway

The server returned an invalid or incomplete response.

Posted by
New Poster
Message 273 of 512
2,584 Views

Just crashed again.  

Posted by
Contributor

Message 274 of 512
2,564 Views

And they tried to tell me it was my error causing my email not to load.  This is the worst email system I have ever seen in terms of consistent operation.

Posted by
Contributor

Message 275 of 512
2,552 Views

This is becoming a habit, every day or every other day. Comcast is not responding, cannot get on and see any of my e-mails. When I am able to get on, the left side on the e-mails, in box, etc. does not show up. When is this going to be fixed?. Getting very frustrated. Yes, I am cleaning out my cache and doing whatever. Getting tired of the oh Snap coming up and sending feedback and nothing happening anyway. Please try and fix this.

Posted by
Email Expert

Message 276 of 512
2,550 Views

silphium wrote:

Now getting this error message.  

 

502 Bad Gateway

The server returned an invalid or incomplete response.


See here for some good information about 502 errors---------------------

 

https://www.lifewire.com/502-bad-gateway-error-explained-2622939

 

It could be your browser, or a number of other things.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Email Expert

Message 277 of 512
2,517 Views
Posted by
New Poster
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 278 of 512
2,470 Views

As of very recently, I no longer have red lines under misspelled words in emails that I'm writing. Is this something that I can change a setting for and get back? If not, is Xfinity ever going to bring it back? I sure hope so, it's pretty inconvenient this way. I'm not used to having to click on spellcheck before sending. Who knows how many of my business emails have gone out with spelling errors. So embarrassing! I know how to spell but typos are inevitable in a busy business day. 

Posted by
Regular Contributor

Message 279 of 512
2,465 Views

I still have the red lines under misspelled words and no option to turn that feature off.  Only spelling options are English or Spanish.  Not sure why you are not seeing the red lines.

Posted by
Frequent Visitor

Message 280 of 512
2,448 Views

This new email client is terrible, ever since it was installed nothing but trouble... Sometimes it will load sometimes not?? Error messages--400 Bad requests, something about 502 being bad??

Your browser sent an invalid request. Then instead of the email loading it goes back to the xfinity home page over and over again just like Groundhog Day...Just today it has been happening again.  Just today it has been happening again.  Just today it has been happening again.  Oooops....Deja Vu

Posted by
Regular Contributor

Message 281 of 512
2,444 Views

Same here.  Keeps reverting to the Xfinity homepage tonight.  Intermittent problems all afternoon.   It's terrible. 

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 282 of 512
2,416 Views

the time on my emails is wrong.  How can I change it?

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 283 of 512
2,403 Views

gillygrrl wrote:

the time on my emails is wrong.  How can I change it?



Under your Xfinity Connect Basic Settings is your time zone setting correct?

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 284 of 512
2,400 Views

The new webmail fails to load almost everytime I try to log into it. My email loads fine on my phone, just not using webmail. I get "failure to load" notifications, see only the 3 dots in the mddle of the screen and nothing ever loads. This is especailly true if I open another tab to try and do something else while the email loads - then it never loads. 

Please either fix the new webmail or go back to the previous version. 

Posted by
Frequent Visitor

Message 285 of 512
2,370 Views

Each day I learn a bit more on how to deal with the ahem, "new" system.

Lots to learn to get back to proficiency I had with old system.

Considerable effort - and Ive not yet found anything that's better.

Also experiencing slow load times.  I'd prefer to go back.

Ron

Posted by
Official Employee

Message 286 of 512
2,354 Views

The red lines under the mispelled words are produced by the browser. The spell check button is provided by the email.

Please check the documentation for your particular browser on how to make sure the spell checking service is enabled.

 

 


akwawmn wrote:

As of very recently, I no longer have red lines under misspelled words in emails that I'm writing. Is this something that I can change a setting for and get back? If not, is Xfinity ever going to bring it back? I sure hope so, it's pretty inconvenient this way. I'm not used to having to click on spellcheck before sending. Who knows how many of my business emails have gone out with spelling errors. So embarrassing! I know how to spell but typos are inevitable in a busy business day. 


 





Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon

Posted by
Contributor

Message 287 of 512
2,323 Views

What new XFINITY Connect email?

 

I never got the update from last April, much less the one from this week -- and I have an email from Comcast in my mailbox telling me to go check out the new webmail site.

 

So I guess I should consider myself lucky that I never got the update at all?

 

Rob

 

ETA: Even if I try to manually enter the Appsuite URL, I am redirected to https://web.mail.comcast.net (the Zimbra site).  What voodoo do I need to do?

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 288 of 512
2,237 Views

Can you tell me if this problem has been corrected yet? I have tried and tried, even with the help of Comcast reps over the phone to no avail! I have tried some of the things I have read on the forums here with the settings gear on the right hand side but no luck in finding "preferences". What is totally bewildering is that all of our other email accounts are still under the old format, only my one main email account is under the new one!  I lose any emails other than the 30 or however many fits on a screen page, soooo frustrating.  

 

Any help is appreciated!!!  Thanks!

Posted by
Email Expert

Message 289 of 512
2,226 Views

"Preferences" is no longer used.  In the new format you just click on the gear icon and you should see such settings as you have control over.  It looks like this------------

 

 

New Format Settings page.jpg




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Email Expert

Message 290 of 512
2,177 Views
Posted by
Regular Contributor

Message 291 of 512
2,183 Views

Yes, the automatic deletion options for deleted items and spam were very useful.  Comcast's decision to remove these options was not smart.  Not smart at all...

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 292 of 512
2,170 Views

This 'New Look and Feel' webmail page is terrible.   What a mess, I can't believe Comcast actually released this.
I'm running fast, clean, PC's, with Win 7 Pro, Win 10 Pro, all other web pages (and other webmail sites) are fine..
But your 'new' Comcast email layout is probably he worst webmail program I've ever seen.
Slow, sluggish, basically a PITA to navigate and arrange email and folders.
You guys really ruined it,  no doubt about it.    
I hate to even use it....

Posted by
Email Expert

Message 293 of 512
2,163 Views

If you don't like the webmail UI, you have a lot of options if you still want to use the account:

 

1)  Enable the account in a desktop email client like Thunderbird or Outlook.  That way you don't have to look at the UI, and no ads either.

 

2)  Set the account to auto-forward to another email account you might have with another email provider like Gmail, Yahoo, Mail.com, etc.

 

3)  Some email accounts like Mail.com, Yahoo, Outlook.com and Gmail have the ability to use a mail fetcher so you can get your Comcast emails in their interface.

 

I think the Comcast webmail is just keeping up with the reality of mobile device users.  It uses the same kinds of icons and other more simplistic qualities found with other providers like Outlook.com or iCloud accounts.  I like it well enough so far, although they have yet to implement a couple of features.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Regular Contributor

Message 294 of 512
2,159 Views

The problem is not with the icons.  The problem is that the new webmail is SLOW.   Admittedly it's getting a little faster than a few weeks ago, but it is still SLOW, much slower than the previous version.  And the missing options such as the email deletion schedule have not gone unnoticed.   

Posted by
Email Expert

Message 295 of 512
2,152 Views

bob0006 wrote:

The problem is not with the icons.  The problem is that the new webmail is SLOW.   Admittedly it's getting a little faster than a few weeks ago, but it is still SLOW, much slower than the previous version.  And the missing options such as the email deletion schedule have not gone unnoticed.   


I am not having any speed issues with it.  Mine seems to work just as fast as the old one.  I have three Comcast accounts right now, one in the new format, and the other two are still on the old format.  So I can compare easily.  You might have something else going on.  As for deletion schedules, one of the many advantages of using a desktop email client is that you have more control over that, and any settings you use will override the ones in the webmail.  At least they do for me using Mac Mail. 




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Email Expert

Message 296 of 512
2,119 Views
Posted by
Contributor

Message 297 of 512
2,110 Views

I'll try again, because apparently we have a self-appointed censor, deciding what you can see, and what I did was offend by including a variaion on the name Comcast, except it rhymes with Comslap, except substitute "cr" at the second syllable. i won't keep up this game much longer, no time, but this is what we're dealing with... 

 


Latoque wrote:
Moved: http://forums.xfinity.com/t5/Removed-Posts/Re-New-Xfinity-Webmail/m-p/2857591#U2857591
Removed ------viol forum posting guidelines------bypassing language filters. http://forums.xfinity.com/t5/Forum-Community/Forums-Policy-and-Guidelines/td-p/2618379

But so why does the first link go somewhere it says is restricted from going to? Why post the link if it goes to an off-limits area?

 

Anyway, the substance of the post was about deletions: Select a bunch of mails, hit the trashcan, and they stay there. You have to hit the refresh, and then sometimes they go away. But the point is that this is BASIC functionality that they can't get right.

And apparently they're too sensitive they can't even SEE a message about it. I'd like to delete my account... 

 

 

 

 

 

 

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 298 of 512
1,984 Views

Why do I need to go thru all folders to move one to it's folder in left pane?

Posted by
Email Expert

Message 299 of 512
1,973 Views

jacee wrote:

Why do I need to go thru all folders to move one to it's folder in left pane?


You need to clarify-------exactly what are you trying to do---move an email, or move a folder?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Regular Contributor

Message 300 of 512
3,011 Views

If my memory serves me correctly, I used to be able to "drag and drop" a message into another folder.  Now I have to select the message, click move then click where to move it to.  That's 3 times as many clicks as before.  Another Comcast "improvement."