Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,682,508

members

52

online now

1,851,083

discussions

Back to Top

New Xfinity Webmail

Posted by
Email Expert

Message 201 of 512
4,206 Views

There is no way for you to change to the new format on your own.  It will just happen whenever Comcast gets around to you.  At some point in time everyone will be migrated to the new format.  In the interim. if you are still on the old format, you can change your sorting options depending on which "View" you are using.  Click on "View" in the toolbar-------which one are you using?  Are you using the one with the reading pane set to the bottom or turned off, or the reading pane set to the right?  In either case, right-click on any message  in the list and you will see this--------------------------

 

 

Message Group by from Message list.jpg

 

 

Pick your criteria.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Regular Contributor

Message 202 of 512
4,200 Views

Reading pane is "off." I didn't like the other options.

How long has the new format been around? I wonder why I haven't been moved to it yet. 

Thanks for your help.

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 203 of 512
4,178 Views

all of my folders are missing since the update.

Posted by
Regular Contributor

Message 204 of 512
4,160 Views

A clarification: this happens only with Comcast webmail. The regular email app that I use with my iPad is fine. 

Posted by
Regular Visitor
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 205 of 512
4,143 Views

In a nutshell, this new email is awful!  It just changed on its own one day.  There no longer is any color to put on folders which helped me locate the folders more easily!  The MAIN PROBLEM is nothing works as far as my preference as to how I want my emails displayed.  I select "From" which is how all my emails were sent prior to this non requested switch.  NONE of the preferences works.  Now there are over 800 emails sitting there because I have to go & check and/or read each one individually!  

 

Something needs to be fixed!  I can't go through all these emails individually.  

 

Can anyone help me?

Posted by
Regular Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 206 of 512
4,041 Views

the folders are most likely there.  I looked for the >> as the previous employee suggested.  My computer screen must be a little off size because when I looked very carefully in the bottom right corner I could just barely see the >> symbol. I clicked and all my folders etc are back on the left side as he suggested.  Look again, maybe it is kind of hidden in the program bar at the bottom.  Good luck!

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 207 of 512
3,997 Views

I am looking for a new emial client right now because your new client is not ready for primetime yet. When you Compose or reply there is no option in the To: area to import addys from your address book. This has been a standard feature of email clients forever!! How can someone who claims to be on the edge of tech put such an unfinished client out to its cutomers.

 

UPDATE: Thank you for doing maintenance today Comcast now when you reply the email address that you are replying to is automatically populated in the To: form box.

Comcast support called me and confirmed it and could close the ticket. Now I have to show my father how to compose in the address book. It is quite easy so this is a tremendous help for routine emailing. My father has Spinal muscular atrophy and is in an electric wheelchair using a remote for his laptop so that reply issue was major for him.

Posted by
Regular Visitor
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 208 of 512
3,925 Views

The "new email?" system stinks! I can't imagine why comcast changed something that was

working perfectly!! If they're smart they won't expand theso-called "new email system" to the

total population and to those who have been changed( against their will) they should go back

to the better system.

 

Posted by
Email Expert

Message 209 of 512
3,896 Views

For the Comcast employees working on the new email format---------------------------------------

 

I have responded to a number of posters who can't see the folders pane to the left of the Inbox message list---------------------

 

http://forums.xfinity.com/t5/Email-Web-Browsing/Where-is-my-sent-folder/m-p/2809952/highlight/false#...

 

I would like to point out that there is almost no contrast for those chevrons.  They are very hard to see and a bit on the small side.  Something to consider in the ongoing rollout of the email format.

 

just sayin




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 210 of 512
3,829 Views

Some features are better, but now when I click on my signature when responding to an email, the signature appears at the very bottom of the thread instead of at the bottom of my email response.  Very annoying!

Posted by
Frequent Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 211 of 512
3,805 Views

Ok, so I changed my view to the horizontal position using the view dropdown menu.  I prefer it that way and have used it that way for years.  But, every time I close it out and come back later, it's all vertical again and I have to manually change it back to horizontal.  Is there some way to save that setting so I don't have to select it each time?

 

Thanks for any help!

Posted by
Email Expert

Message 212 of 512
3,787 Views

ga5150 wrote:

Ok, so I changed my view to the horizontal position using the view dropdown menu.  I prefer it that way and have used it that way for years.  But, every time I close it out and come back later, it's all vertical again and I have to manually change it back to horizontal.  Is there some way to save that setting so I don't have to select it each time?

 

Thanks for any help!



Try clearing out your browser's cache/browsing history. When you have done that, close out the browser and re-start it in a fresh session.

If that doesn't do it, then try using a different browser and see if you can duplicate the problem that way.  There is no setting you can change to lock it in place.  It should just hold on it's own.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Official Employee

Message 213 of 512
3,750 Views

GA5150

If following Latoque's excellent reccommendations don't rectify the problem, please reach out to me and I will get our team to look at what may be going on.

Thank you for reaching out.


Brett





Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon

Posted by
Email Expert

Message 214 of 512
3,734 Views

Removed----off topic. Please start your own thread if you have a question not related to this one.

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 215 of 512
3,737 Views

When i transfered to new email format I lost many of folders to the left of the email box.  How do i get them back??

Posted by
Email Expert

Message 216 of 512
3,728 Views

See this thread----------------------

 

 

http://forums.xfinity.com/t5/Email-Web-Browsing/email-files/m-p/2813173#M169048




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 217 of 512
3,665 Views

This interface is awful.  It will not load unless I go to the mobile site.  I get a great deal of email in a given day.  The interface seems to have difficulty with that.  What the heck did you do... go back to the other interface ASAP.

 

Thanks

Ron

Posted by
New Poster
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 218 of 512
3,574 Views

I'm getting a lot of error messages such as server is timed out.  Xfinity Connect is slow to open, sometimes I only get a blank white page and have to close the tab on my brower and start again.  I'm using My Xfinity under Chrome and have problems getting photos to attach.  I've had to go back and open Firefox when I want to send a photo.  Ridiculous.  Wasn't any wrong with the previous program.

Posted by
Regular Visitor
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 219 of 512
3,562 Views

this is what i get (and 3 support people could not fix it, they think it's my settings):  I'd appreciate someone with knowledge reach out to me or FIX it!  for now, at least one phone support person was able to forward my email to gmail after i flipped out on him.  Very Frustrating when support does not know how to deal with error messages and starts with resetting my password!

 

HTTP Status 500 - Request processing failed; nested exception is java.lang.NullPointerException


type Exception report

message Request processing failed; nested exception is java.lang.NullPointerException

description The server encountered an internal error that prevented it from fulfilling this request.

exception

org.springframework.web.util.NestedServletException: Request processing failed; nested exception is java.lang.NullPointerException
	org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:978)
	org.springframework.web.servlet.FrameworkServlet.doGet(FrameworkServlet.java:857)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:620)
	org.springframework.web.servlet.FrameworkServlet.service(FrameworkServlet.java:842)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
	org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52)
	com.comcast.cima.login.agent.session.RealmSessionAuthnAgentFilterImpl.doFilter(RealmSessionAuthnAgentFilterImpl.java:92)
	com.comcast.cima.login.agent.BaseRealmAuthnAgentFilter.doFilter(BaseRealmAuthnAgentFilter.java:67)

 

root cause

java.lang.NullPointerException
	com.comcast.cable.xcpreauth.service.MailBoxService.getEflStatusUrl(MailBoxService.java:647)
	com.comcast.cable.xcpreauth.service.MailBoxService.getSwanService(MailBoxService.java:607)
	com.comcast.cable.xcpreauth.controller.XcPreAuthController.index(XcPreAuthController.java:140)
	sun.reflect.GeneratedMethodAccessor54.invoke(Unknown Source)
	sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	java.lang.reflect.Method.invoke(Method.java:606)
	org.springframework.web.method.support.InvocableHandlerMethod.invoke(InvocableHandlerMethod.java:215)
	org.springframework.web.method.support.InvocableHandlerMethod.invokeForRequest(InvocableHandlerMethod.java:132)
	org.springframework.web.servlet.mvc.method.annotation.ServletInvocableHandlerMethod.invokeAndHandle(ServletInvocableHandlerMethod.java:104)
	org.springframework.web.servlet.mvc.method.annotation.RequestMappingHandlerAdapter.invokeHandleMethod(RequestMappingHandlerAdapter.java:781)
	org.springframework.web.servlet.mvc.method.annotation.RequestMappingHandlerAdapter.handleInternal(RequestMappingHandlerAdapter.java:721)
	org.springframework.web.servlet.mvc.method.AbstractHandlerMethodAdapter.handle(AbstractHandlerMethodAdapter.java:83)
	org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:943)
	org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:877)
	org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:966)
	org.springframework.web.servlet.FrameworkServlet.doGet(FrameworkServlet.java:857)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:620)
	org.springframework.web.servlet.FrameworkServlet.service(FrameworkServlet.java:842)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
	org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52)
	com.comcast.cima.login.agent.session.RealmSessionAuthnAgentFilterImpl.doFilter(RealmSessionAuthnAgentFilterImpl.java:92)
	com.comcast.cima.login.agent.BaseRealmAuthnAgentFilter.doFilter(BaseRealmAuthnAgentFilter.java:67)

 

note The full stack trace of the root cause is available in the Apache Tomcat/7.0.57 logs.


Apache Tomcat/7.0.57

Posted by
New Poster
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 220 of 512
3,551 Views

Yes, customer support blamed it on Chrome and had be reset to default.  I said I didn't want to do that as I'd lose all my passwords.  After being told it wouldn't, hah, it certainly did!  If there is going to be customer support, these people need to be trained and not reading from manuals that were probably written in China and then poorly translated.

Posted by
New Poster
  • Great Job! Your reply has been accepted. Thank you for helping and Congrats on your 1st Solution.
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 221 of 512
3,538 Views

This new email is HORRIIIIIBBBLLLLEEE!  It is sooooooooooo slow and when it displays the folders, the numbers are superimposed on top of the folders....not all the time, but some of the time.  Then sometimes it just keeps thinking to get into a folder or just get back to the inbox.   They gave it to my husband for his email, but not mine.  He has a hard enough time with the email that was there before.  I don't know why you cannot give people the option of keeping what they have or upgrading.  This is getting ridiculous!  Not EVERYONE needs the super duper EVERYTHING!  I pay over 300.00 a month for TV and Internet alone and I should be able to choose the email program that I would like to keep!  I have a host account for my web site since 1998 with a company for my business and I have been able to use Squirrel mail since 1998.  They have other options, but they give me the CHOICE!  That is what it should be about....CHOICE!

 

Signed: Smiley Sad

New Poster
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 222 of 512
3,479 Views

I had this exact same problem this past week.  Comcast finally got all my folders back, but now all my sent emails show up as "no recipient"  "no content" when I send from webmail.  From my phone they are fine.  also have trouble that group messages are not being received.

Posted by
Regular Visitor
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 223 of 512
3,428 Views

How is this solved???  I'm able to now open my email, but it's empty except for 3 new emails!!!

Posted by
Email Expert

Message 224 of 512
3,353 Views
Posted by
New Poster
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 225 of 512
3,262 Views

THIS IS THE ABSOLUTE WORST EMAIL SYSTEM I HAVE EVER EXPERIENCED.  PLEASE PLEASE PLEASE SCRAP IT AND GO BACK TO THE OLD SYSTEM WHICH WORKED JUST FINE!!!!

Posted by
Frequent Visitor

Message 226 of 512
3,175 Views

When in doubt; use a different program.  There are plenty of free programs...use them for a while. 

****Trust is not something you will find on your computer right now; go elsewhere, and make a change.  What do you have to lose?

 

Gotechgirl

Posted by
Email Expert

Message 227 of 512
2,959 Views
Posted by
New Poster
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.
  • Congrats on Posting your first topic!

Message 228 of 512
3,120 Views

Your new and improved email system is a total disaster.  

Posted by
New Poster
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 229 of 512
3,004 Views

New -- Yes.  Improved -- NNNNOOOOOOOOOOO!!!!!!

 

Slow to open

Constant server timeouts

Deleted messages reappear in the in box

Messages moved to other folders rerappear in the in box

Did I mention SLOW and CONSTANT server timeouts???

 

Advanced technical support said we had to install Chrome to get it the web email interface to work.  We did that, and the only change was MORE ANNOYING ADS sinced my adblockers don't work with Chrome.

 

PLEASE UNDO THIS NEW INTERFACE!!!!!

Posted by
Regular Contributor

Message 230 of 512
2,986 Views

I hadn't been switched over to the new interface but got an email the other day saying "Your New My Account Is Here."  Should I not make the switch? Do I have a choice? 

I've read nothing but horror stories about it.

Posted by
New Poster
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 231 of 512
2,975 Views

You don't have a choice.  I finally gave up yesterday and switched to Thunderbird which is less convenient because it works outside your browser.  The "new" Xfinity email program does not work consistently within Chrome.  I would get white screen, error messages, messages wouldn't send or delete.  Tech support had me change settings back to default and assured me I wouldn't lose my passwords.  Surely enough; all username and passwords gone.  Recommend you start researching alternative email programs.

Posted by
Regular Contributor

Message 232 of 512
2,971 Views

Does it work well within Safari? And is Xfinity webmail affected by this?

Posted by
New Poster
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 233 of 512
2,957 Views

I'm still using Chrome, but don't access my Comcast email within it.  No, I've had no problem using Thunderbird and also accessing Xfinity's webmail.  So far, everything's there that should be.

Posted by
Email Expert

Message 234 of 512
2,953 Views

stevetefft wrote:

Does it work well within Safari? And is Xfinity webmail affected by this?


I'm on an iMac and it works OK for me in Safari.  Also works in Firefox and Chrome.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
New Poster
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 235 of 512
2,826 Views

i thought updates made things run easier, faster and smooth.this new email is slow,laggy and more difficult to use get it together comcast we are going into 2017 yet xfinity email reminds me of windows 95 on a bad day

Posted by
Frequent Visitor

Message 236 of 512
2,830 Views

Well Comcast you finally did it, you managed to take probably the one thing I didn't have any problems with ( emails) and give me nothing but problems. <Edited for violating forum guidelines: "Flaming Remarks">. You call this new email system "new & improved" ??? Are you kidding me? Not only does it look & feel like 1990's tech but I'm lucky if I can even get my email to come up 50% of the time. Feels like this new email system is straight out of a Commodore 64!

 

At least half the time when I click on my email it goes to a white blank page and says fault in the address. Then the other half the time when it actually does come up it is only after sitting there for 15 seconds waiting for the page to load. Oh, then there is the lovely "you have unsaved drafts would you like to delete" message that comes up 75% of the time for no reason what so ever.

 

I could go on & on but whats the point. <Edited for violating forum guidelines: "Flaming Remarks"> for the 4 yrs we've been customers I know it is pointless to waste my time trying to tell you what the issues are because it won't do anything but fall on deaf ears. After this holiday season we will be looking into other providers for our internet/tv/phone because just when you think <Edited for violating forum guidelines: "Flaming Remarks"> can't possibly get ANY worse guess what, <Edited for violating forum guidelines: "Flaming Remarks"> now with the worst email system I have seen since nearly two decades ago.

 

 

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 237 of 512
2,798 Views

Exactly! This is terrible. It seems as though this new format hasn't been tested fully. The performaces should be compaired to the former, making certain it delivers better.

Posted by
Regular Contributor

Message 238 of 512
2,794 Views

I am holding off switching as long as possible. Seems like I should send all the emails I have in my box to another email service, just to back them up if--when--the new Comcast system chews them up and spits them out.

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 239 of 512
2,777 Views

I AGREE 100%!

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 240 of 512
2,571 Views

I want to use my email address as my display name like it was before the change!  Now I have my full name displayed and I do NOT like it.

Posted by
Official Employee

Message 241 of 512
2,561 Views

Jill-SM,

 

I replied to your other post in the forums, but I will reply here also.

 

There are two ways to do this in the new format:

Click on the little gear icon and choose settings.
Click Account on the left, then next to Email, click Edit
You will see a field "Your Name" that you can edit to change your Display Name.
Click Save

OR

Click Compose
At the end of your from name click the little down arrow
Choose Edit names
You can check the box and change the name to whatever you want it to be. Or uncheck it to have it match your Display Name.
Click Save

 

***If you only want your email address displayed, click the down arrow and choose Hide name.





Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 242 of 512
2,534 Views

Hate this new email program. As usual our opinions won't matter.

Posted by
Email Expert

Message 243 of 512
2,527 Views

unionbroad wrote:

Hate this new email program. As usual our opinions won't matter.


Did you have a specific question about something in the email?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor

Message 244 of 512
2,488 Views

I have a specific question about the new email system. How am I supposed to use it when it is down more than it is up???!!!! Yet again today for at least the past few hours I get nothing but that blank white screen saying "failure". This is just flat out ridiculous. We have had nothing but problems every since they changed this email a couple months ago. I find it absurd that this new email system seems to be down just as much as it is up. What are we paying for??

Posted by
New Poster
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 245 of 512
2,466 Views

I'm just sitting in front of a white screen waiting for Xfinity's email to access its server.  Sometimes none of my message even show up, I have to exit out of the program and start again.  A real time waste.

Posted by
Valued Contributor

Message 246 of 512
2,459 Views
Mine keeps saying that imap.email.comcast.net either refused to connect or timed out. So I'm guessing it's a current server issue. Right now I can't send nor receive messages. Now that I just refreshed it, now it says that the server is down.
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 247 of 512
2,438 Views

The NEW email interface for comcast is the WORST!!!!!!!

They took the worst template on the web ie Yahoo and copied it and made it worse.

 

Try searching for an email with a key word,  you have to search in every email folder.. thats hundreds?  What is the point of the search function if you have to look in every single email folder

 

Good case example in taking something that works and making it almost unusable.

 

Posted by
Email Expert

Message 248 of 512
2,428 Views

lareindorf wrote:

The NEW email interface for comcast is the WORST!!!!!!!

They took the worst template on the web ie Yahoo and copied it and made it worse.

 

Try searching for an email with a key word,  you have to search in every email folder.. thats hundreds?  What is the point of the search function if you have to look in every single email folder

 

Good case example in taking something that works and making it almost unusable.

 


They are working on providing that functionality.  But I have no timeline on it yet.  You might consider enabling the account in a desktop client like Outlook, Thunderbird or some other.  Then you could use the search features in them.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Email Expert

Message 249 of 512
2,412 Views

For ComcastBrett or anyone else working on the new email format, here is an issue to be worked on:  I have dealt with one or two posters in the forum who have said they cannot use drag and drop in the Inbox if they are using Chrome or IE-11 on a Windows machine.  My desktop is an iMac, and I have not experienced this issue there.  However, if I use my Dell Windows 10 laptop, I cannot use drag and drop in either IE_11 or Chrome, yet it works OK in Firefox, Edge, or Safari on the Mac.

 

Just sayin.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 250 of 512
3,201 Views

I have just had the new web mail forced on me and I hate it.  The nameless icons don't tell you what they do until you hover over them.  That means I have to try each one till I find the one I want. Bring back the old web mail.  Change for the sake of nothing else but change is just a waste of everyones time