Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,683,853

members

13

online now

1,852,186

discussions

Back to Top

New Xfinity Webmail

Posted by
Contributor

Message 501 of 513
482 Views

I doubt they would do a rewind even if they could. That would mean they'd have to admit the new version is a real goof up. Have had Comcast email more years than I can remember with only a few glitches  and then this new one was paraded out with quite a bit of misery in its wake.  I'm stilling having some slight problems but they're small enough for me not to bother with at this point.

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 502 of 513
421 Views

If you are using an application for you to access your email like outlike or MacMail more likely you wont see the folders transfered to the application but if you have been using the website for you to access email try to search for the email folder or the email itself on the search option on top of your inbox folder. If the problem is still there try to clear cache and cookies on the browser if you are using safari browser clear your recent history. Or you can use private browser or incognito browser. I hope this will help

Posted by
Contributor

Message 503 of 513
365 Views

 


Latoque wrote:

 The only time you would not see them there is if you are using a client and have the account set up using POP3 and it's default setting, which is to download and then delete the messages from the server.  But even in POP that can be changed to leave copies on the server.

I use POP3, and when I was switched over, "Keep" was pre-ticked in the Xfinity Mail Advanced/POP settings.  But in a uniquely-confusing twist of wording, choosing "Delete" does NOT actually mean the emails will be deleted after Outlook downloads them.  Instead, choosing "Delete"  means "allow your application to tell the server what to do."  In my email account settings in Outlook, I have both "Leave a copy of messages on server" and "Remove from server when deleted from 'Deleted Items'" ticked.  And in Xfinity Mail I chose Delete.  I was hesitant to do that at first, but verified that ticking "Delete" in the Xfinity POP options does indeed make it instead follow the options I selected in Outlook.  They really need to change that convoluted wording, though it works well once you figure out what to do.

 

EDIT:  I just realized that the POP Settings you are referring to might be settings within the client (Outlook in my case), as opposed to the Xfinity Mail "POP Setting for Other Apps."  But my comments about how the Xfinity Mail setting actually works (including the odd wording) still apply.

pop.JPG
Posted by
Regular Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 504 of 513
317 Views

Good afternoon,

The trouble we have experienced since this new roleout is that the inbox changes when you reply to or forward an e-mail.  For instance, if I recieve and email from "Jenny@aol.com" and respond to it, the sender changes from "Jenny@aol.com" to my e-mail address.  So it looks as though I sent the e-mail to myself.  This is frustrating, for obvious reasons.  However, what really makes this difficult is that you loose the original senders e-mail address, and you can no longer respond to them.

 

I spent hours trying to explain this to the help desk via the phone, and they cannot seem to understand the problem. 

 

Thanks for any advise you can offer.

Posted by
Regular Contributor

Message 505 of 513
313 Views

????  This is how email works.  When you forward or reply to an email, you become the sender.     The real problem with the email is that it is still slow and nobody seems to be complaining about that lately.

Posted by
Regular Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 506 of 513
302 Views

Nope, you're not getting the issue.  Look at your inbox.  See the e-mails and who they are from?  Repsond to any of them, and it changes their name to your name.  You no longer see who the original sender was.  That is not how e-mail works!!!

Posted by
Regular Contributor

Message 507 of 513
293 Views

You need to go to settings, mail, and check the box that reads "insert the original text into the reply" or something like that.  Then the incoming message will be sent, with headers, along with the reply. 

Posted by
Regular Contributor

Message 508 of 513
269 Views

There is a saying "If it ain't broke don't fix it" and this applies to the new E-Mail presentation from Comcast.  At least when we received E-Mail before this stupid change we could read our mail in continuity.  The first day that my "new" E-Mail arrived I could only see a few E-Mails and thought that was all of the mail that I had received.  Luckily my tablet showed an abundance of E-Mail that I was not aware of.  I then went back to my computer and lo and behold all of that E-Mail was there but I had to access it with the "up" button.  If Comcast was going to change our E-Mail the least they could have done was to issue an E-Mail letting us know of the changes.  And for the life of me, I cannot understand why they just don't leave our E-Mail alone and stop making these stupid unwanted un-needed changes, and in particular, without letting us know of these changes. 

Posted by
Regular Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 509 of 513
246 Views

tnhldesrosiers wrote:

Nope, you're not getting the issue.  Look at your inbox.  See the e-mails and who they are from?  Repsond to any of them, and it changes their name to your name.  You no longer see who the original sender was.  That is not how e-mail works!!!



Hmm.. doesn't do that in my inbox...  maybe some setting needs to be changed.. I'll scroll down to see if anyone else has suggested something.. that's WEIRD. 

Posted by
Official Employee

Message 510 of 513
229 Views

I'm sorry for any confusion. You can turn off Conversation View to stop this behavior from happening. Instructions can be found here. 

How do I turn off conversation view?

Our engineers are looking into changing how conversation view works in the future.

 

 


tnhldesrosiers wrote:

Good afternoon,

The trouble we have experienced since this new roleout is that the inbox changes when you reply to or forward an e-mail.  For instance, if I recieve and email from "Jenny@aol.com" and respond to it, the sender changes from "Jenny@aol.com" to my e-mail address.  So it looks as though I sent the e-mail to myself.  This is frustrating, for obvious reasons.  However, what really makes this difficult is that you loose the original senders e-mail address, and you can no longer respond to them.

 

I spent hours trying to explain this to the help desk via the phone, and they cannot seem to understand the problem. 

 

Thanks for any advise you can offer.


 





Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon

Posted by
Regular Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 511 of 513
219 Views

This worked, thank you!  You should let the customer support people know about this as well. 

Posted by
Frequent Visitor

Message 512 of 513
203 Views

Are you using quick reply?  Seems like something something similar happened to me and I decided to not ever use quick reply again.  You lose the email addresses that were in the conversation.  Try both ways of replying and see if quick reply is the problem for you.

The other problem I have is putting email addresses in an email without first adding them to my address book.  Maybe I don't need them in my address book.  In the old system, I could highlight them and add a long list.  I finally got the format of a list of people's emails in my list to send, and then it told me it couldn't send them because I had too many.  So I just did it on gmail.

Posted by
Contributor

Message 513 of 513
50 Views

But this is stupid. The DEFAULT position should be that it continues to display the way it has.

If you want to implement some cockamamie new view, then put in a setting somewhere. I don't think I changed to conversation view. Why would I? I'm just getting used to this new "improvement."

Of course it doesn't work right - sometimes the top message is collapsed, and you have to click the down-arrow and wait for it to display.... WHY!!!???

 

 

 


ComcastBrett wrote:

I'm sorry for any confusion. You can turn off Conversation View to stop this behavior from happening. Instructions can be found here. 

How do I turn off conversation view?

Our engineers are looking into changing how conversation view works in the future.