Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,684,406

members

50

online now

1,852,782

discussions

Back to Top

Microsoft Edge and the my.xfinity.com page

Posted by
New Poster
  • Congrats on Posting your first topic!

Message 1 of 2
184 Views

MS Edge, go to my.xfinity.com. Page loads except for the top navigation bar with the sign in, home button, email button.The bar is blank except for the hamburger on the left corner but that doesn't work. Page works fine in Chrome and firefox just not in Edge. Problem also does not appear on other PC's running edge just this one. Any help appreciated. 

1 REPLY
Posted by
Email Expert

Message 2 of 2
146 Views

I just tried it on a Windows 10 laptop and I get the usual things at the top of the page.  I have other issues with Edge right now, but not with the sign-in.  Try signing out of Edge and back in again.  Also clear browsing history.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon