Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,810,125

members

34

online now

1,955,272

discussions

Top

Mac OS X - Proper postfix configuration for SMTP

ANSWERED
Frequent Visitor

Mac OS X - Proper postfix configuration for SMTP

I am trying to use the built-in Mac SMTP service to allow emails to be sent from localhost, but something is not quite set up correctly. What are the correct entries to put into the postfix main.cf file? This is what I have in it right now:

 

### MAMP Postfix Configuration - Start ###

myorigin = comcast.net
myhostname = mailer.$myorigin
smtpd_sender_restrictions = permit_inet_interfaces

# smart host
relayhost = smtp.comcast.net
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_MAMP_passwd
smtp_sasl_security_options = noanonymous

 

Can anyone see what is wrong with this?

Accepted Solution

Re: Mac OS X - Proper postfix configuration for SMTP

After taking a break from this topic for a while, I FINALLY found the combination of settings that allow me to route emails through Comcast SMTP servers. The settings are as follows:

 

In /etc/postfix/main.cf, put:

 

 

# Comcast settings
relayhost = [smtp.comcast.net]:587
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/saslpass
smtp_sasl_security_options = noanonymous

 (note: MUST put square brackets around SMTP server in relayhost entry)

 

 

In /etc/postfix/saslpass, put:

 

smtp.comcast.net login@comcast.net:password 

 

In /etc/postfix/transport, put:

 

# Comcast settings
*     :[smtp.comcast.net]

  

At terminal prompt, type the following commands:

 

postmap hash:transport
postmap hash:saslpass
postfix reload

 

Test system by using following from terminal:

 

telnet localhost 25
ehlo testmail.org
mail from:<test@testmail.org>
rcpt to:<cactus@virtualdomain.tld>
data
This is a test email.
 
.
quit

 

If you get a message like:

 

250 2.0.0 Ok: queued as B746E283BE2A

 

Then postfix has accepted the request

 

Check /var/log/mail.log for something like:

 

Oct 23 13:00:18 Michael-Sheavers-iMac postfix/smtpd[1554]: connect from localhost[127.0.0.1]
Oct 23 13:01:40 Michael-Sheavers-iMac postfix/smtpd[1554]: B746E283BE2A: client=localhost[127.0.0.1]
Oct 23 13:02:03 Michael-Sheavers-iMac postfix/cleanup[1556]: B746E283BE2A: message-id=<20111023190140.B746E283BE2A@Michael-Sheavers-iMac.local>
Oct 23 13:02:03 Michael-Sheavers-iMac postfix/qmgr[1489]: B746E283BE2A: from=<michael@michaelsheaver.com>, size=369, nrcpt=1 (queue active)
Oct 23 13:02:05 Michael-Sheavers-iMac postfix/smtp[1557]: B746E283BE2A: to=<msheaver@me.com>, relay=smtp.comcast.net[76.96.30.117]:587, delay=56, delays=55/0.01/1.1/0.51, dsn=2.0.0, status=sent (250 2.0.0 oK0z1h00L2wgXwz01K10kE mail accepted for delivery)
Oct 23 13:02:05 Michael-Sheavers-iMac postfix/qmgr[1489]: B746E283BE2A: removed
Oct 23 13:02:09 Michael-Sheavers-iMac postfix/smtpd[1554]: disconnect from localhost[127.0.0.1]
Oct 23 13:15:12 Michael-Sheavers-iMac postfix/qmgr[1489]: C61D7283BD47: from=<test@testmail.org>, size=355, nrcpt=1 (queue active)
Oct 23 13:15:12 Michael-Sheavers-iMac postfix/smtp[1575]: C61D7283BD47: to=<msheaver@me.com>, relay=smtp.comcast.net[76.96.30.117]:587, delay=2778, delays=2777/0.02/0.37/0.26, dsn=2.0.0, status=sent (250 2.0.0 oKEt1h00o2wgXwz8jKEuWR mail accepted for delivery)
Oct 23 13:15:12 Michael-Sheavers-iMac postfix/qmgr[1489]: C61D7283BD47: removed

 If you see "mail accepted for delivery", then your message has successfully gone through.

 

It feels so good to have finally found a solution to tis perplexing issue!

View answer in context
Networking Expert

Re: Mac OS X - Proper postfix configuration for SMTP

While Comcast used to allow this kind of customer SMTP server (years ago), over time they have added restrictions mandated by the sheer volume of spam and abuse to the point where it's near impossible to run a full function SMTP server on a residential account.  Bottom line - it's not going to work reliably unless you have a business account and have setup your own domain with static IP's and reverse DNS lookup.

 

It's been a long time since I've played with Postfix and other SMTP mailers, but if all you are looking for is a way to relay OUTBOUND messages, there's probably a way to set them up to look like submission clients, ie. using 587 with SASL to look like a normal email client.  There are how-to's posted on many places on the web, but since I have not tried any, I won't recommend one.  Do a search and give them a try.

 

Inbound is also possible, but you're going to run into issues, beyond the necessary DNS setup with MX record, etc.  Comcast in many instances will block port 25 traffic at your modem if they detect any significant traffic and and that will effectively cut you off from receiving email from outside domains via your SMTP server.

 

Also bear in mind that running a server is against the Acceptable Use Policy, although the language is a little fuzzy if the server is just for your personal non-commercial use.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Frequent Visitor

Re: Mac OS X - Proper postfix configuration for SMTP

Essentially, I have set up a MAMP server on my MacBook to be a test and development platform for my Wordpress blog site (michaelsheaver.com), which is hosted at another ISP. Like you guessed, I am only interested in outgoing emails that are generated by testing of changes to my site (plugins, etc).

 

I discovered (almost by accident) that my emails were being blocked by Earthlink. I contacted them about it, and they responsed quickly, pointing me eventually to the following PBL advisory. This totally supports your observations, big time!

 

Thank you so much for sharing your insights on this matter!

 

 

Networking Expert

Re: Mac OS X - Proper postfix configuration for SMTP

That PBL is incorrect, at least at face value.  I can certainly send email directly through external SMTP servers.  For example as a test, I just sent a message to my Gmail account through the MoblieMe SMTP server using Mac Mail.  No Comcast mail server involved.  Worked like a champ.  The same is true for other email clients like Outlook Express, etc.  

 

That's not to say some other system, like EarthLink doesn't have other rules that would make this a problem.  It could very well see a Comcast originating IP and not a Comcast domain in the sender address and say that's not allowed.  But that's not a Comcast restriction, that would be Earthlink's issue.  This is simply an example for illustrative purposes, I have no idea what if any restrictions Earthlink uses.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Frequent Visitor

Re: Mac OS X - Proper postfix configuration for SMTP

Well, that is interesting indeed. For according to Spamhaus, my IP (75.71.122.136) is blacklisted. Here is what Earthlink sent back to me via email:

 

Hello *****@earthlink.net,

Your host has been blocked because it is listed with one or more RBLs.

Please click on the links below and find out which RBL you are listed
with and get information on how to get removed.

Spamhaus
http://www.spamhaus.org/query/bl?ip=75.71.122.136

SORBS
http://www.us.sorbs.net/overview.shtml

If you feel that the RBL listing(s) is(are) in error or that there is
an exception in their listing that includes your IP, please reply to
this email and include the necessary information.

Once you have been removed from the RBL, please send a new email to
blockedbyearthlink@abuse.earthlink.net with

Blocked <IP address>

in the subject line and your IP will be removed within 24 hours.

Regards,

--
Earthlink Abuse Department
blockedbyearthlink@abuse.earthlink.net
http://www.earthlink.net/about/policies/use.faces

 

Networking Expert

Re: Mac OS X - Proper postfix configuration for SMTP

You need to talk to Earthlink, they are the ones using the Spamhaus PBL for exclusion.  That policy is designed to disallow any Comcast customer from sending through any server but Comcast's.  It's not a Comcast restriction, but a restriction designed by a 3rd party and used by other 3rd parties.  

 

Running your own SMTP server is getting more and more difficult because of problems caused by spammers is driving legitimate ISP's to be more and more restrictive.  Look at it from EarthLink's perspective.  They know that many user systems are infected and acting like spam bots, so they are suspicious of emails sent directly from some other ISP, bypassing tht ISP's regular email servers.

 

You have two choices:

 

1. Talk EarthLink and get them to relax that restriction.  Good luck with that.

 

2. Relay your messages through smtp.comcast.net.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Bronze Problem Solver

Re: Mac OS X - Proper postfix configuration for SMTP


msheaver wrote:

Well, that is interesting indeed. For according to Spamhaus, my IP (75.71.122.136) is blacklisted. Here is what Earthlink sent back to me via email:

 

 All of Comcast's residential addresses are listed by Spamhaus and SORBS, as are almost all of the residential addresses of all ISPs around the world. That's all it means. But, most ISPs around the world will refuse email sent *directly* from those addresses as that's where the spambots tend to live. The problem with Earthlink just indicates that your smarthosting setup isn't working, that you're trying to send directly to Earthlink. You should be OK when you get the smarthosting working. I don't know anything about Postfix, but, did you restart Postfix after editing the config file?

 

I don't quite understand the bit about emailing them after you get removed from a blocklist, but it doesn't matter, you're *not* going to be removed from those lists.

 

Bronze Problem Solver

Re: Mac OS X - Proper postfix configuration for SMTP


Baric wrote:

You need to talk to Earthlink, they are the ones using the Spamhaus PBL for exclusion.  That policy is designed to disallow any Comcast customer from sending through any server but Comcast's.  It's not a Comcast restriction, but a restriction designed by a 3rd party and used by other 3rd parties. 



Actually, that stuff about having to use Comcast's SMTP servers isn't PBL policy. Comcast have complete control of their PBL records, including that descriptive text.

Frequent Visitor

Re: Mac OS X - Proper postfix configuration for SMTP

As a former network engineer and a current computer security officer, I can fully appreciate and understand why Earthlink and other ISPs would implement this kind of policy. That is why I will not even try option 1 suggested by Baric above. So, to go back to my original post in this forum thread,I just need to tweek my Postfix settings to enable routing of emails through the Comcast SMTP servers. If I do figure that out, I will put the solution here for future reference by others who encounter the same problem.

Email Expert

Re: Mac OS X - Proper postfix configuration for SMTP

I don't understand all these replies.  He's not trying to send directly to Earthlink, he has his Postfix set up to go through the Comcast server:

 

relayhost = smtp.comcast.net

 

Maybe port 25 has been blocked on your modem. In that cast, you need to change that to:

 

relayhost = smtp.comcast.net:587

 

Also, I'm not sure if Comcast supports SASL authentication. So try using:

 

smtp_auth_enable = yes

smtp_password_maps = hash:/etc/postfix/sasl_MAMP_passwd




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Frequent Visitor

Re: Mac OS X - Proper postfix configuration for SMTP

Nope, it still did not work. Here are the entries from /var/log/mail.log:

 

 

May 21 08:32:21 Michael-Sheavers-MacBook postfix/pickup[9171]: BC97510CCE42: uid=502 from=<michaelsheaver>
May 21 08:32:21 Michael-Sheavers-MacBook postfix/cleanup[9172]: BC97510CCE42: message-id=<139e2f447fdc8e92c8d79554ca318678@localhost>
May 21 08:32:21 Michael-Sheavers-MacBook postfix/qmgr[3731]: BC97510CCE42: from=<michaelsheaver@comcast.net>, size=1202, nrcpt=1 (queue active)
May 21 08:32:22 Michael-Sheavers-MacBook postfix/smtp[9174]: BC97510CCE42: to=<msheaver@earthlink.net>, relay=smtp.comcast.net[76.96.30.117]:587, delay=1, delays=0.17/0.01/0.77/0.07, dsn=5.1.0, status=bounced (host smtp.comcast.net[76.96.30.117] said: 550 5.1.0 Authentication required (in reply to MAIL FROM command))
May 21 08:32:22 Michael-Sheavers-MacBook postfix/cleanup[9172]: BAFB110CCE47: message-id=<20110521143222.BAFB110CCE47@mailer.comcast.net>
May 21 08:32:22 Michael-Sheavers-MacBook postfix/bounce[9179]: BC97510CCE42: sender non-delivery notification: BAFB110CCE47
May 21 08:32:22 Michael-Sheavers-MacBook postfix/qmgr[3731]: BAFB110CCE47: from=<>, size=3136, nrcpt=1 (queue active)
May 21 08:32:22 Michael-Sheavers-MacBook postfix/qmgr[3731]: BC97510CCE42: removed
May 21 08:32:23 Michael-Sheavers-MacBook postfix/smtp[9174]: BAFB110CCE47: to=<michaelsheaver@comcast.net>, relay=smtp.comcast.net[76.96.30.117]:587, delay=0.48, delays=0/0/0.41/0.06, dsn=5.1.0, status=bounced (host smtp.comcast.net[76.96.30.117] said: 550 5.1.0 Authentication required (in reply to MAIL FROM command))
May 21 08:32:23 Michael-Sheavers-MacBook postfix/qmgr[3731]: BAFB110CCE47: removed

 

It appears that postfix initially tried to send the original email, then it immediately tried to send a non-delivery notification. Both attempts failed with the error:

 

550 5.1.0 Authentication required

 

 Here is the entry in /private/etc/postfix/sasl_MAMP_passwd:

 

smtp.comcast.net:587	msheaver:********

 

Here is the entry from /private/etc/postfix/sasl_MAMP_passwd.db:

 

msheaver:********smtp.comcast.net:587 (extra characters stripped for display here)

 

The port number in the two passwd files was previously set to 465, so I manually edited them to 587. In my days as a unix admin, I remember that there was a command that needed to be run after making manual changes to passwd file; is that the case here? If so, what is the command?

 

Do you see anything else that might be wrong here?

Email Expert

Re: Mac OS X - Proper postfix configuration for SMTP

The page I got the information from is

 

http://systems.takizo.com/2010/03/26/configure-smarthost-smtp-authentication-on-postfix/

 

It shows the command "/etc/init.d/postfix reload" to tell Postfix to reread its configuration file. However, I think that path is for Linux. I googled for postfix on mac, and found this page:

 

http://www.david-reitter.com/software/osxpostfix.html

 

which says to do "sudo postfix reload".




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Regular Visitor

Re: Mac OS X - Proper postfix configuration for SMTP

Barmar:

 

I followed the instructions on the page in your post...

 

http://systems.takizo.com/2010/03/26/configure-smarthost-smtp-authentication-on-postfix/

 

However, I was not able to execute the following command: 

 

shell> postmap hash:$P
postmap: fatal: open : No such file or directory

The error in the mail log says:

 

May 23 00:30:31 halkyard postfix/postmap[21876]: fatal: open : No such file or directory

---snip---

 

I don't see a file or directory even referenced here.  Is this a major problem ?  Is the postmap command critical to the security of my sendmail system if exposed to the outside ? 

 

However, the test mail did work. 

 

Thanks in advance, 

-thsk

 

LINUX Fedora 14

Email Expert

Re: Mac OS X - Proper postfix configuration for SMTP

I really don't know anything more about this than I can find with Google. If you're having trouble following the instructions on a web page, I suggest you try contacting the author.

 

That "postmap hash:$P" command doesn't look at all right to me. $P is a variable reference in the shell, but the variable P has never been set. I have no idea what his intent was. According to the documentation, the syntax of that command is "postmap hash:filename"

 

Another good place to ask for help would be in the forums at discussions.apple.com.

 




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Networking Expert

Re: Mac OS X - Proper postfix configuration for SMTP

I agree with Barmer.  I expect that poster had a previous "set P=smarthosts.conf" set in his session so this command worked.  Just substitute the smarthosts.conf file for $P, like this:

 

$ postmap hash:smarthosts.conf

 

I can't try this out here, my Gentoo Linux server doesn't have Postfix installed at the moment and I don't want to add it just now, I'm in the middle of a project there.  If I get a few minutes later, I'll try it on my Mac.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Frequent Visitor

Re: Mac OS X - Proper postfix configuration for SMTP

After taking a break from this topic for a while, I FINALLY found the combination of settings that allow me to route emails through Comcast SMTP servers. The settings are as follows:

 

In /etc/postfix/main.cf, put:

 

 

# Comcast settings
relayhost = [smtp.comcast.net]:587
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/saslpass
smtp_sasl_security_options = noanonymous

 (note: MUST put square brackets around SMTP server in relayhost entry)

 

 

In /etc/postfix/saslpass, put:

 

smtp.comcast.net login@comcast.net:password 

 

In /etc/postfix/transport, put:

 

# Comcast settings
*     :[smtp.comcast.net]

  

At terminal prompt, type the following commands:

 

postmap hash:transport
postmap hash:saslpass
postfix reload

 

Test system by using following from terminal:

 

telnet localhost 25
ehlo testmail.org
mail from:<test@testmail.org>
rcpt to:<cactus@virtualdomain.tld>
data
This is a test email.
 
.
quit

 

If you get a message like:

 

250 2.0.0 Ok: queued as B746E283BE2A

 

Then postfix has accepted the request

 

Check /var/log/mail.log for something like:

 

Oct 23 13:00:18 Michael-Sheavers-iMac postfix/smtpd[1554]: connect from localhost[127.0.0.1]
Oct 23 13:01:40 Michael-Sheavers-iMac postfix/smtpd[1554]: B746E283BE2A: client=localhost[127.0.0.1]
Oct 23 13:02:03 Michael-Sheavers-iMac postfix/cleanup[1556]: B746E283BE2A: message-id=<20111023190140.B746E283BE2A@Michael-Sheavers-iMac.local>
Oct 23 13:02:03 Michael-Sheavers-iMac postfix/qmgr[1489]: B746E283BE2A: from=<michael@michaelsheaver.com>, size=369, nrcpt=1 (queue active)
Oct 23 13:02:05 Michael-Sheavers-iMac postfix/smtp[1557]: B746E283BE2A: to=<msheaver@me.com>, relay=smtp.comcast.net[76.96.30.117]:587, delay=56, delays=55/0.01/1.1/0.51, dsn=2.0.0, status=sent (250 2.0.0 oK0z1h00L2wgXwz01K10kE mail accepted for delivery)
Oct 23 13:02:05 Michael-Sheavers-iMac postfix/qmgr[1489]: B746E283BE2A: removed
Oct 23 13:02:09 Michael-Sheavers-iMac postfix/smtpd[1554]: disconnect from localhost[127.0.0.1]
Oct 23 13:15:12 Michael-Sheavers-iMac postfix/qmgr[1489]: C61D7283BD47: from=<test@testmail.org>, size=355, nrcpt=1 (queue active)
Oct 23 13:15:12 Michael-Sheavers-iMac postfix/smtp[1575]: C61D7283BD47: to=<msheaver@me.com>, relay=smtp.comcast.net[76.96.30.117]:587, delay=2778, delays=2777/0.02/0.37/0.26, dsn=2.0.0, status=sent (250 2.0.0 oKEt1h00o2wgXwz8jKEuWR mail accepted for delivery)
Oct 23 13:15:12 Michael-Sheavers-iMac postfix/qmgr[1489]: C61D7283BD47: removed

 If you see "mail accepted for delivery", then your message has successfully gone through.

 

It feels so good to have finally found a solution to tis perplexing issue!

New Poster

Re: Mac OS X - Proper postfix configuration for SMTP

thankyou so much.  i have been trying for 2 days to make it  work on my ubuntu system.

then, i followed your instructions and it worked

New Poster

Re: Mac OS X - Proper postfix configuration for SMTP

@ msheaver:


I could not be more grateful for your diligence in getting this configuration sorted out, then circling back to inform the community.   You, Sir or Madam, are my hero.

 

For anyone doing this in RedHat, CentOS, or Oracle Enterprise Linux -- I had the following error which required one more step:

 

550 5.1.0 <myuser@myhost.mydomain.com> sender rejected : invalid sender domain (in reply to MAIL FROM command)

 

A quick look around http://postmaster.comcast.net/smtp-error-codes.php gave me the answer.

 

After adding an A record for myhost.mydomain.com to my domain's zone file, everything works!

 

Now to switch my domain to a registrar that offers Dynamic DNS updates.... but that's another day.

 

New Poster

Re: Mac OS X - Proper postfix configuration for SMTP

Way to go!  You rock!  I'm running Yosemite, followed your instructions and it works perfectly!

 

Thank you!

 

New Poster

Re: Mac OS X - Proper postfix configuration for SMTP

I get lost when I get to this step.

 

postmap hash:transport
postmap hash:saslpass
postfix reload

Can you please give more details? What am I doing here? I'm a command line noob. And I'm using nano.