Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,809,634

members

24

online now

1,954,992

discussions

Top

MS Edge Browser Does Not Display Images in Many Emails

ANSWERED
Regular Contributor

MS Edge Browser Does Not Display Images in Many Emails

Other browsers will display the images. MS Edge stopped displaying images embedded via links after a recent update of Windows 10.

Accepted Solution

Re: MS Edge Browser Does Not Display Images in Many Emails

This may be fixed now. Images are coming across in all emails using MS Edge browser. I also notice Comcast made some layout changes to webmail page. The "Help" link has moved from menu bar to a "?" between your profile and Settings gear icon. 

View answer in context
Regular Contributor

Re: MS Edge Browser Does Not Display Images in Many Emails

Adding, that the emails that do not display images in Xfinity webmail using MS Edge, when forwarded to my gmail account, display all images just fine using MS Edge in the gmail web page. Further, the problem emails that have the option to show the email in a web page display just fine in an MS Edge browser web page. So while the issue may only arise when using MS Edge, it is only the Xfinity webmail webpage that will not display images in MS Edge. Therefore, the problem is more likely rooted in faulty Xfinity web page programming than with coding in the MS Edge browser.

Regular Contributor

Re: MS Edge Browser Does Not Display Images in Many Emails

I just got off the phone with the Comcast advanced tech team after an initial call yesterday to first level support. They are aware of the issue with MS Edge and webmail images not displaying. They claim to be working with MS to resolve what they describe as a browser incompatibilty issue. They recommended using IE or Chrome to check webmail until it is resolved.

Contributor

Re: MS Edge Browser Does Not Display Images in Many Emails

Thank you for updating the status and probable cause of this issue.

 

 

Email Expert

Re: MS Edge Browser Does Not Display Images in Many Emails

I will also suggest using a different browser for now.  I cannot duplicate this problem on my Windows 10 machine using Edge.  Photos come across just as they should in Comcast emails.   I also tried using Firefox, Chrome and even Brave.  They all work as expected with images in Comcast email.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Regular Contributor

Re: MS Edge Browser Does Not Display Images in Many Emails

This may be fixed now. Images are coming across in all emails using MS Edge browser. I also notice Comcast made some layout changes to webmail page. The "Help" link has moved from menu bar to a "?" between your profile and Settings gear icon.