Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,807,851

members

11

online now

1,953,714

discussions

Top

Lost Emails

New Poster

Lost Emails

Is there a way to retrieve email that are missing from my inbox?

These emails were not deleted, they are just missing to review.

Feb, March, May June, July are missing almost all emails on my amlebar email account and also missing emails on my dancindiva4ever account.

 

Please reply to my amlebar email account ASAP as the email I'm looking for is very important.

Gold Problem Solver
Moved:

Re: Lost Emails

Moved to its own thread. Click the link to go to your post and replies to it.

Gold Problem Solver

Re: Lost Emails

Most likely you did not adjust your email settings in Xfinity a connect.
Open the Inbox and click on PREFERENCES. Next click on the EMAIL ICON. Now you see all your settings. Scroll down to tyevEMAIL DELETION SCHEDULE and open it.

Now look at the number of days each FOLDER is set to automatically delete all email from the Fooder. While there, make any changes you wish to make to the days forvEACH a folder.

Does that explain the missing emails? If not, do you also use another email program, smartphone, or tablet? If yes, which one?

You can search for the mist recent deleted email if you use the Full version of Xfinity a Connect.
To check: Open XfinityConnect, click on Preferences in the Preview window. Now click on the General tab. A window opens showing which version you are using.


RIGHT CLICK on the Trash Folder of XC. Click on Recover deleted email. A new window opens showing deleted email. Any email you see there can be recovered by:
Highlight the email
Click on the small green arrow that appears on the top left of the window. Another window opens where you can then move that email message back to your Inbox.
CC


Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.