Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,806,747

members

11

online now

1,952,674

discussions

Top

Login problem with Safari

Frequent Visitor

Login problem with Safari

I am using Safari v10.0.3, Mac OS X Sierra's latest.  When I try to log in from the Comcast home page using the Sign In button, Email button or Home button I end up with a blank page.  I can, however, log in via the TV button.  I have cleared the entire browser cache.  That does not fix the login problem. This is a new behavior.

 

Both Chrome and Firefox login pages display properly.

 

Any suggestions to get Safari login properly working? 

Contributor

Re: Login problem with Safari


RickCunn wrote:

I am using Safari v10.0.3, Mac OS X Sierra's latest.  When I try to log in from the Comcast home page using the Sign In button, Email button or Home button I end up with a blank page.  I can, however, log in via the TV button.  I have cleared the entire browser cache.  That does not fix the login problem. This is a new behavior.

 

Both Chrome and Firefox login pages display properly.

 

Any suggestions to get Safari login properly working? 


Per my many phone calls to Comcast they told me they were aware of this problem and it was at their end not my computer and related to the extensive issues over the past weekend.  So at least you are not alone. I chose to sign in through my account button and then save the page as a bookmark before I signed in so that I did not have to poke around the main page. Today they could not give me time frame for a total fix but that I would get a credit on next month's bill for the inconvenience and a call after the system isses were completed from an upper level technician to make sure everything was working correctly. The agent was very knowledgeable about the situation.

 

Hope this is helpful to you. I had the same issues with Edge and Windows 7 machines as well.