Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,841,423

members

702

online

36,040

topics

Top

IE11 or Edge with Google search will not function correctly

New Poster

IE11 or Edge with Google search will not function correctly

When I open my Home Page to xfinity.com, I get the Google search bar on the page. I then type in something to search for and the whole computer acts like it is frozen. No results or wait 10 minutes and something will come uo. This is not true if I use Bing as search engine.

Email Expert

Re: IE11 or Edge with Google search will not function correctly


Try clearing out your browser's cache/browsing history. When you have done that, close out the browser and re-start it in a fresh session. If that doesn't do it, then try using a different browser.  If it still does it, as a test, try going directly to the Google website and try a search from there.  If it works you will at least know it's something to do with the Xfinity homepage.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Xfinity Events:
WATCHATHON 2018... See More
Discussion stats
  • 1 reply
  • 187 views
  • 0 kudos
  • 2 in conversation