Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,807,867

members

24

online now

1,953,729

discussions

Top

I keep getting the spinning wheel when using my email

New Poster

I keep getting the spinning wheel when using my email

Lately whenever I use my Comcast Xfinity email I get the spinning color wheel.  Then it won't do anything.  I have to sign out of my email and open the program again.  it might work for a while and then the wheel comes back.  Happens when I try to delete multiple emails, open and send emails.  Kind of intermittent.  Sometimes it works and sometimes not but now it seems to happen more frequently.  If anyone can help I'd apprecitate it thanks.....

Email Expert

Re: I keep getting the spinning wheel when using my email


Try clearing out your browser's cache/browsing history. When you have done that, close out the browser and re-start it in a fresh session.  If that doesn't do it, then try using a different browser.  I also had to re-start my computer.  If you do that, close out of anything you have running first.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: I keep getting the spinning wheel when using my email

Thanks very much for your reply and I will try that.....

New Poster

Re: I keep getting the spinning wheel when using my email

I have been having this problem for weeks.  I have called Comcast several times.  I have been told it is a known problem and that they are working on it.  Hard to understand how it could take weeks to get it fixed.  During this time I have frequently gotten email from Comcast when I sign on.  Email says I have signed on and there is nothing I need to do if it was indeed me.  Seems to indicate there is some sort of security issue as well.

Email Expert

Re: I keep getting the spinning wheel when using my email


ccastb wrote:

I have been having this problem for weeks.  I have called Comcast several times.  I have been told it is a known problem and that they are working on it.  Hard to understand how it could take weeks to get it fixed.  During this time I have frequently gotten email from Comcast when I sign on.  Email says I have signed on and there is nothing I need to do if it was indeed me.  Seems to indicate there is some sort of security issue as well.


Those emails are a new security feature.  If you clear browsing history in your browser, or close it out, or if you shut down your computer and restart it, you will get that same email.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: I keep getting the spinning wheel when using my email

I have had the same problem for 2-3 weeks.  Have also talked to SEVERAL comcast agents, have had 2 technicians come out, etc.  Cleaning out the cache/browsing history does not solve the problem.  I now use google chrome until this gets resolved, if ever.  I'm beginning to lose confidence in Comcast in their desire to resolve this.  If it is not resolved in the next couple of weeks, I will look at other options.

New Poster

Re: I keep getting the spinning wheel when using my email

This has been happening for weeks and is EXTREMELY frustrating. Please fix this issue.