Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,858,463

members

1,344

online

29,718

topics

Top

I am not able to send my e-mails. I hit the send button and nothing happens.

New Poster

I am not able to send my e-mails. I hit the send button and nothing happens.

HELP!   I can not send e-mails.  I hit the send button and nothing happens.

Email Expert

Re: I am not able to send my e-mails. I hit the send button and nothing happens.


Try clearing out your browser's cache/browsing history. When you have done that, close out the browser and re-start it in a fresh session. If that doesn't do it, then try using a different browser.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

New Poster

Re: I am not able to send my e-mails. I hit the send button and nothing happens.

I don't know if comcast fixed the problem or not.  They said that other people called with the same problem.  One day I hit  the send button and it worked. I got no phone call from comcast telling me it was fixed.

Forums Tips and Tricks:
Tagging Posts... See More
Discussion stats
  • 2 replies
  • 206 views
  • 0 kudos
  • 2 in conversation