Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,872,865

members

1,030

online

28,851

topics

Top

Firefox not loading pages - TLS problem?

ANSWERED
Regular Contributor

Firefox not loading pages - TLS problem?

Is anyone else having problems with Firefox suddenly not loading pages?

 

Two evenings ago (March 8) Firefox suddenly started not loading pages about 80% of the time on all three of our PCs.I've noticed TLS messages in the lower left corner where Firefox displays the URLs it is loading that I never noticed before.

 

All three of our PCs are configured the same and we changed nothing on any of them before this started other than routine anti-virus and anti-malware updates. Visits to support forums for those products don't have any reports of problems like this.

 

We are in Baltimore County, MD.

 

Thanks for any input.

Accepted Solution

Re: Firefox not loading pages - TLS problem?

It appears this was a problem caused by an update to Malwarebytes Anti-Exploit that was released on or around March 8.

 

Uninstalling MBAE fixes the problem.

View answer in context
Email Expert

Re: Firefox not loading pages - TLS problem?

I'm not having this issue.  I can load pages normally in Firefox.  Did you try clearing history/cache?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Frequent Visitor

Re: Firefox not loading pages - TLS problem?

I am having this issue with tv.xfinity.com. Seems like it has to do with IPv6, but haven't heard a fix other than disabling IPv6.

Regular Contributor

Re: Firefox not loading pages - TLS problem?

It appears this was a problem caused by an update to Malwarebytes Anti-Exploit that was released on or around March 8.

 

Uninstalling MBAE fixes the problem.

Special Events
FIFA World Cup 2018 on Xfinity See More
Discussion stats
  • 3 replies
  • 390 views
  • 0 kudos
  • 3 in conversation