Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,807,464

members

78

online now

1,953,338

discussions

Top

Email not being sent

New Poster

Email not being sent

I have an intermittent problem when sending comcast email using the Xfinity mail browser page. This happens when I'm logged into my account at work on a Dell PC, or at home on my Mac, and has happened with both Firefox and Safari. Occasionally when I send an email to a friend (I always cc myself too), I get no error message and the email seems to have been sent, and if I look in the "Sent" mail folder it shows up there. But I don't receive it in my inbox, nor does the other recipient. But most of the time it works fine... it is just once in a while. It is very annoying because I count on the fact that when I send a message, it really gets sent! Has anybody had this problem or know what causes it?

Tags (3)
Official Employee

Re: Email not being sent


David290 wrote:

I have an intermittent problem when sending comcast email using the Xfinity mail browser page. This happens when I'm logged into my account at work on a Dell PC, or at home on my Mac, and has happened with both Firefox and Safari. Occasionally when I send an email to a friend (I always cc myself too), I get no error message and the email seems to have been sent, and if I look in the "Sent" mail folder it shows up there. But I don't receive it in my inbox, nor does the other recipient. But most of the time it works fine... it is just once in a while. It is very annoying because I count on the fact that when I send a message, it really gets sent! Has anybody had this problem or know what causes it?


Hello David290,

 

I'm sorry you are having problems sending some mail out. Based on your description of the problem I took this to our Anti-Abuse team and had them take a look. As I suspected, there is something in those particular emails that is triggering the global spam filters. (Not just Comcast, other vendors would flag it as well). Since it hits the spam trigger upon sending, the message is dropped. I have had the team remove the block for the time being, but there is no guarantee that it won't happen again (it's an automated system, not manual). 

 

Without knowing specifics, I can only guess at what is triggering the flag. Often times it is a sender's Signature which might contain a phone number or URL that trips the spam filter. I would look at the messages that didn't send and see if there is a common element. Sometimes, the URL or phone number can be flagged if it is used in spam campaigns that are completely out of your control. 

 

In summary, the flag has been removed, but if this issue occurs in the future, your best recourse is to reach out to our CSA team and they can assist you further.

 

Customer Security Assurance

The Customer Security Assurance organization has been established to ensure a safe and secure online experience for Comcast customers. This team is a dedicated group of security professionals who respond to issues pertaining to phishing, spam, infected computers (commonly referred to as bots), online fraud and other security issues.

  • Business Hours: 6:00am - 2:00am EST, 7 days a week
  • Contact: 1-888-565-4329

 





Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon