Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,725,763

members

52

online now

1,887,874

discussions

Back to Top

Email bar does not show Preferences anymore

Posted by
Frequent Visitor

Message 1 of 7
247 Views

After Comcast changed the email, I noticed that the Preferences choice is no longer there where I can block certain email addresses, etc.  How can I get that back?  (I tried calling Comcast and they said they could see it, but I can't, so I'm hoping someone can help.)

6 REPLIES
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 2 of 7
243 Views

I have the same problem. I have 2 email addresses registered on my account. When I log onto one of them the screen shows up with the preferences option. If I log onto the other one a different email screen is opens without the preferences option. I also called Comcast support and they don't have a clue.

Posted by
Email Expert

Message 3 of 7
224 Views

For both of you------------in the new email format, click on the small gear icon in the upper-right corner of the page near your name, then on Settings.  That's where you will find all the options for your account.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor

Message 4 of 7
212 Views

Some preferences are missing from the gear icon like "Email deletion schedule"

Posted by
Email Expert

Message 5 of 7
205 Views

mpnret wrote:

Some preferences are missing from the gear icon like "Email deletion schedule"


There are differences, yes.  In the new format, there are no longer schedules that you can edit.  All folders, with two exceptions, will retain messages indefinitely until you delete them.  The two exceptions are Trash, which is set at 7 days, and Spam which defaults to 30 days.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor

Message 6 of 7
132 Views

I tried going into the Settings through the gear but I don't find the ability to block email addresses in there.  And I didn't see an option to make Preferences visible in the bar like it used to be.  I appreciate your attempt to help me, but I still have the same issue.  Thanks again for trying.

Posted by
Email Expert

Message 7 of 7
121 Views

The word "Preferences" does not and will not appear as it did in the old format.  As for blocking someone, you do it the same way you could before;  set up a filter for that sender.  After you Click on Settings, under Mail you should see Filter Rules.  Click on that and set up your filter.  You can also do it right from the email.  Open the message from that sender, and in the toolbar above it, click on the "hamburger" icon at the right end.  There you will see a menu with the option to set up a filter.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon