Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,708,118

members

35

online now

1,871,910

discussions

Back to Top

Email Settings for Android Phone

SOLVED
Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 1 of 32
70,725 Views
Need the incoming and outgoing mail settings for my HTC EVO.
1 ACCEPTED SOLUTION

Accepted Solutions
Posted by
Silver Problem Solver

Message 2 of 32
74,987 Views
Solution

zdunk31 wrote:
Need the incoming and outgoing mail settings for my HTC EVO.

Hello,

Try these settings:

Comcast's email servers are POP3, the server name is mail.comcast.net.  You can use port 110 for plaintext email, or 995 with SSL for encrypted email (recommended).

 

For sending mail, the server smtp.comcast.net.  You can use port 25, 465, or 587.  With 587, you must have authentication, and I would recommend TLS (may be referred to simply as SSL as with many clients).

31 REPLIES
Posted by
Silver Problem Solver

Message 2 of 32
74,988 Views
Solution

zdunk31 wrote:
Need the incoming and outgoing mail settings for my HTC EVO.

Hello,

Try these settings:

Comcast's email servers are POP3, the server name is mail.comcast.net.  You can use port 110 for plaintext email, or 995 with SSL for encrypted email (recommended).

 

For sending mail, the server smtp.comcast.net.  You can use port 25, 465, or 587.  With 587, you must have authentication, and I would recommend TLS (may be referred to simply as SSL as with many clients).

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 3 of 32
70,695 Views
TY, worked perfectly !
Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 4 of 32
70,185 Views

I too have an HTC EVO, and my husband has an HTC EVO Shift.  We've had intermittent failures for months on outgoing mail. My present streak is over a week long now, using all the combos of 25, 465, 587 with security set to None,SSL,TLS.  Wireless On (Using both my Comcast Broadband and my employer's internet connection), Wireless Off (4G/3G). It seems to either work with ALL options or NONE.

 

Customer Service (over two calls) stated, among other things, 465 was WRONG (never recommended), must be Sprint, port 587 goes with security set to None, and for a day or so, both incoming and outgoing (even on my Win 7 laptop, using Thunderbird) was dead for all secondary email accounts. That turned out to be inadvertent suspension on their end from my first trouble call?

 

Sigh, in at least 3 occurances where we've gone as far as calling customer service, we've never gotten to the bottom of this. It used to work to change the port and security settings to 'something other than' what they were presently set at.  Not this time.  Outgoing on my phone still fails. 

 

(HTC EVO 4G/Android 2.3.3/Sprint)

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 5 of 32
70,131 Views

Leslie...I'm having the very same issue's (outgoing only)...with my LG....I'm convienced it's a comcast problem.

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 6 of 32
70,026 Views

I'm having the same problems. Played around with the different setting mentioned above. Had email workingfor a while then I changed something and it's not working now. Can't text either.

 

Sprint on new Motorola Photon.

Posted by
Frequent Visitor
  • You have posted 10 replies to the community. Thank you for keeping the conversations going!
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 7 of 32
67,274 Views

I've been having recurring problems with incoming e-mail on my Droid2 Global (Verizon). After 15 months of working perfectly, the incoming mail suddenly stopped a couple of weeks back. After deleting and adding the e-mail account on my Droid2 (at Motorola's suggestion), the service was restored for a few days, up until last night (4/5/2012). As I do every night, I turned the phone off. This morning (4/6/2012), after I turned the phone on, the problem has reappeared. Is there something about the settings provided by Motorola for Comcast e-mail accounts (https://motorola-global-portal.custhelp.com/app/answers/detail/a_id/55835) that's incorrect? Could there be some server issues at Comcast's end? Thank you.

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 8 of 32
64,376 Views

I just had to re-set my Droid Razr MAXX and the Comcast settings for it have apparently changed recently -- it took the Comcast tech several tries to get it right! So for everyone's sanity here's what worked:

 

Incoming

mail.comcast.net

port: 995

use secure connection: Check

Use secure password (TLS): Never

Authentification: password

 

Outgoing:

smtp.comcast.net

port: 465

use secure connection: Check

Use secure password (TLS): Never

Authentification: None

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 9 of 32
62,991 Views

Here's the setting that work on my Razr Maxx:

 

Outgoing server settings:

 

SMTP server:                smtp.comcast.net

Username                     WhatYouUse@comcast.net

Password:                     your password

Advanced Settings:

        Port                                           465

        Use Secure Connection            Check this box

        Use Secure Password              Never

        Authentication                           Auto

 

Good Luck

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 10 of 32
61,860 Views

Obviously neither one of you are using ICS, because the security setitings are not the same. Post your settings when you have ICS installed on the phone.

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 11 of 32
56,456 Views

Thank you, worked like a charm

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 12 of 32
55,448 Views

This was super helpful.  I am posting the settings for Comcast email on the T-Mobile MyTouch 3G Slide that work for my wife and me since many of the categories are a bit different.  Comcast could not really help.  Neither could T-Mobile.. They have an 'engineers ticket' to call me back in 3-6 days -- but we figured this out in the interim.

 

  We spent lots of time on this so hope this will save time for others...!!

 

First, type in email address name@comcast.net

 

Incoming:

Protocol:  POP

Email Address:  name@comcast.net

username: name@comcast.net -- our user name does not include 'comcast.net' normally but does here

Password: your password here

POP Server: mail.comcast.net

Security Type: SSL

Server Port: 995

 

Outgoing Server settings

Login Required:  check this box

Username: name@comcast.net

Password: type your password here

SMP server: smtp.comcast.net

Security Type: SSL

Server port: 465

 

Account name: add your account name

Your name:  your name or email address

 

that should work for you - hope it does!!

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 13 of 32
52,232 Views

MY SAMSUNG GA LAXEY S 3 HAS THE RIGHT SETTINGS OF 465 AND 995 BUT WHEN IT CHECKS SETTING IT SAYS SERVER NOT RESPONDING.  THE GMAIL WORKS FINE.  WHAT IS WRONG WITH THE COMCAST SERVICE?  WHAT SHOULD I DO NOW?  HOWARD MCINTOSH IN SEDONA, AZ.  HELP

Posted by
Gold Problem Solver

Message 14 of 32
52,222 Views

kayehoward wrote:

MY SAMSUNG GA LAXEY S 3 HAS THE RIGHT SETTINGS OF 465 AND 995 BUT WHEN IT CHECKS SETTING IT SAYS SERVER NOT RESPONDING.  THE GMAIL WORKS FINE.  WHAT IS WRONG WITH THE COMCAST SERVICE?  WHAT SHOULD I DO NOW?  HOWARD MCINTOSH IN SEDONA, AZ.  HELP


You live in my favorite part of the United States

 

Do you have SSL on for both Settings on your phone?



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 15 of 32
52,218 Views

YES, I HAVE FULL COMCAST SERVICE WITH TWO EMAIL ACCOUNTS.  MY SETTING ARE BOTH SSL.  I AM USING ATT WIFI AT THE RESORT AND GMAIL WORKS FINE.  I HAVE DOLPHIN FOR THE BROSER ON THE PHONE.  NO RESPONCE FROM THE COMCAST SERVER ON OUTGOING FAILED MESSAGES.  PASSWORDS ARE THE SAME ON BOTH EMAIL ACCOUNTS.  TRIED TO SEND PHOTOS OF THE

'RED ROCKS' TO THE KIDS BUT FRUSTRATED.   HOWARD

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 16 of 32
52,002 Views

Same here. Comcast server just stopped responding. Sounds too much like Apple, gonna have to get rid of it. I think the idiots at comcast again changed something without caring to notify people. 

I'm getting rid of their crappy overpriced service, but still need to connect in the meantime. Somehow.

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 17 of 32
51,990 Views

WHAT DOES   'ADD TAG' MEAN AS A REPLY TO MY PROBLEM. 

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 18 of 32
48,285 Views

Port 25 fixed it!! THANK YOU THANK YOU THANK YOU!!!

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 19 of 32
47,383 Views

I can't connect my cell phone to comcast e-mail account. I have a Samsung Galaxy Stratosphere II. We I try to set up my account my phone can't find the server or the server won't reply. Please advise what to do

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 20 of 32
42,748 Views

I've tried all the ports from previous recommendations, with all combinations of security type settings on my wife's Samsung Stratosphere. Every time I get the message:

 

"Setup could not finish. Server not responding. (java.net. SocketTimeoutException: Connection timed out)"

 

Here's where I'm pulling my hair out - it works perfect on my Motorola Droid Razor Maxx using these settings:

smtp.comcast.net

port 465

security type SSL

Authentication Method - Plain (didn't see this option on my wife's Stratosphere)

username: myname@comcast.net

password: mypassword

 

Does anyone have feedback setting up outgoing email on Comcast specific to the Samsung Stratosphere?

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 21 of 32
38,856 Views

my e-mail is not coming into my htc evo design.  this just started4 days ago. my e-mail is coming into my pc  help

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 22 of 32
38,851 Views

I don'tknow how to impliment these directions

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 23 of 32
26,435 Views

I have the Samsung S5 using Verizon and my comcast email will work for awhile than quit. I have do delete the account than add it back. It will than work for a week maybe longer. But it will fail again. I have 2 comcast email accounts. One will work when the other one quits. They both will stop but at differant time.

 My settings are just as most have listed.

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 24 of 32
24,220 Views
Tried all 3, 25 465 and 587 with SSL and still cant send mail. This problem just started out of the blue. One day it was working, the nect it wasnt
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 25 of 32
23,953 Views

Outgoing settings for Samsung Note 4 Port 587, TLS now my outgoing e-mail works with those settings on COMCAST.

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 26 of 32
20,266 Views

I have an Android Maxx.  It receives comcast email until about 3 pm then it stops receive email until the next morning.  I would like to change the settings but your directions only provide the settings, not where to insert this information on the phone.  Please advise.  Thank you. 

Posted by
Service Expert

Message 27 of 32
20,258 Views

jgbolling wrote:

I have an Android Maxx.  It receives comcast email until about 3 pm then it stops receive email until the next morning.  I would like to change the settings but your directions only provide the settings, not where to insert this information on the phone.  Please advise.  Thank you. 


Have you looked at the Razr's manual?  Looked around for settings when you're in email?

 

We can't provide specific instructions for every phone made.

 

FWIW, Comcast offers an email app in the Google Play store.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 28 of 32
16,884 Views

have been following the posts on getting comcast email up and running on android phone.  I have a Moto E and absolutely none of the settings are working.  Very frustrated.  Anything new out there?  No matter what I do (SSL, so SSl, 995, 110, 587, etc) I get a No Connection message which is odd because everything else works including my other email addresses with other ISPs.  Thanks.

Posted by
Service Expert

Message 29 of 32
16,863 Views

dpenn wrote:

have been following the posts on getting comcast email up and running on android phone.  I have a Moto E and absolutely none of the settings are working.  Very frustrated.  Anything new out there?  No matter what I do (SSL, so SSl, 995, 110, 587, etc) I get a No Connection message which is odd because everything else works including my other email addresses with other ISPs.  Thanks.


For simplicity, you could install the Xfinity CONNECT App and access your emails there...  you only need to login to the APP to get it to work.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 30 of 32
16,818 Views

Hi Ray:  Thanks for the reply.  I was on the phone with Comcast last night forever and ultimately, what you advise is precisely what I did.  The bummer is I have to open 2 different email clients on my droid to view mail from my various accounts (not all are Comcast, thank god) but that's life.  Again, thanks for your help

Posted by
Administrator

Message 31 of 32
2,128 Views
Posted by
Administrator

Message 32 of 32
2,127 Views