Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,808,612

members

68

online now

1,954,473

discussions

Top

Email Issues

New Poster

Email Issues

Within the last few days, I have started to encounter issues with my web/desktop Xfinity email access.

 

When I connect to the Xfinity email web program, it works fine initially.  However, after reading or sending one or two emails, all of a sudden the web page locks up.  There is a spinning cirle that appears on the left of the web tab, indicating that the web page is loading, processing, etc.  However, that circle does not go away, and the web page is completely unresponsive.

 

Note that, while the Xfinity web page is unresponsive, I CAN still access other tabs and websites in the same browser window without issue.  So, it is not the browser that is locking up, but specifically the Xfinity email page.  

 

While the Xfinity email page is locked up, I cannot reload the page.  The only solution that works is to close the tab, and reopen it.  Doing so will allow me to read or send a couple of emails before it again locks up.

 

I have replicated this issue across multiple browsers (Chrome, Explorer, Firefox) and with different computers.

 

Note that I have been using the web-based Xfinity email program for years without issue.  None of my computer settings, including firewall, virus, etc. have been changed or altered, so I highly doubt that this issue is happening to to any conflict settings with the computers that I have tried.

 

Can someone let me know if this is an issue that appears to be wide-spread, and if there is currently a solution that is being worked on?  Right now, I can really only access my email from my phone, and as my phone does not have access to the thousands of emails that have been sent from my desktop computer or laptop, this is causing a big issue.

 

Thanks for any help that you can provide.

 

Jay

 

 

Email Expert

Re: Email Issues

Pick one computer, and one browser.  Clear cache and browsing history in it, then re-start the browser in a fresh session.  What you are describing is very typical of a browser with corrupted cookies, TIFs or other files in it.  I know of no widespread problem of this kind in the Comcast webmail.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon