Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,807,767

members

87

online now

1,953,670

discussions

Top

Email Filters will not Run

New Poster

Email Filters will not Run

When in preferences, I have tried to use the "RUN" function for the filters I have set up. They will not work in Chrome, IE or Firefox. They are working on incoming emails and filtering them to the correct folder. However, I am not able to run the filter against my inbox to organize past emails. This has been down for a long time, as far back as September according to forum searches. 

New Poster

Re: Email Filters will not Run

I am a new subscriber and am experiencing the same problem.  Everything is set correctly, but when I select "run" and pick a folder to run against, nothing happens.

 

It would be nice if someone from Comcast would actually respond to this problem with a fix or just be honest and say it doesn't work.

Regular Visitor

Re: Email Filters will not Run

My filters will not run either for incoming mail or on demand. I am only using the web version on the comcast site at this time due to a computer crash. I always had filters in my client and they worked great. I could really use the filters to work at the server level. It would help a lot.

New Poster

Re: Email Filters will not Run

glad to know I"m not the only one.  anyone get it working?

New Poster

Re: Email Filters will not Run

Has anyone got a filter to run?  I have a very simple filter based solely on date.  When Ireceive the message"select a folder to run this filter against" and select a folder, nothing happens.

New Poster

Re: Email Filters will not Run

Same issue!  Looks to be a rather old issue that has not yet been addressed.  I've created filters from the Action pull-down and from the Preference tab.  Neither will fun on Inbox files.

 

Has anyone figured out a work around, or contacted Comcast support?

Regular Visitor

Re: Email Filters will not Run

Problem not solved.  Is there anybody out there Comcast?

Tags (1)
New Poster

Re: Email Filters will not Run

Same problem here today.  Clearly Comcast don't know how to fix this issue.

Email Expert

Re: Email Filters will not Run

This is one of the quirks in Comcast email.  I can't get that "Run" command to work either.  The filters will usually work, but just not that command when you create the filter.  I've got two filters that have the habit of turning themselves off every few days too.

 

This is yet another reason some of us in here recommend people use an email client like Outlook, Thunderbird, Windows Live Mail or some other when using their Comcast email.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Regular Visitor

Re: Email Filters will not Run

I too am having this problem and would like to see it fixed. Comcast, please reply!!

New Poster

Re: Email Filters will not Run

I recently started using filters - because I figure it would be a bit smoother to set up specific filters at the server level - rather than in my mail clients.  The filters work just fine and for the most part are doing what I want them to do.  However - I have never been able to manually run a rule by clicking the run button.  When I click the run button - I get a window with my folder tree displayed.  I can select a folder (such as inbox) and I assume that I am telling it the folder for which I want the filter to run - however - after selecting the folder there is no indication of whether the filter is running - and no indication that anything has happened.  I also noticed that there is no way in the filter window to reorder the filters - you can only add a new filter to the top of the list.  Additionally within a specific rule definition which contains multi-line criteria or multi-line actions - to remove a criteria or an action - and no way to insert a criteria or action after a selected one.  Overall not a very useful interface.

Regular Visitor

Re: Email Filters will not Run

Years ago the run feature worked and it worked in the way you described.  When they changed the folder you wanted the spam to go to to "junk" instead of folder, the run feature no longer worked.  Apparently comcast just doesn't care.  In addition all of my spam comes through Romania and a particular spammer using the "from" name "Just Viral" no matter how I set it up in the filters still goes into my in box.  Also the hot keys don't work very well there is some kind of glitch in them.  The coders at comcast are well, no Steve Wosniak.

New Poster

Re: Email Filters will not Run

I have recently been getting the "Just Viral" emails.  I'm filtering them out on the mail client side.  I did open a ticket with support about the Mail Filter issues - not sure if it will get anywhere.  What is unclear is whether Comcast has direct control over some of these features or whether they are 3rd party apps that Comcast maybe cannot easily fix.

Email Expert

Re: Email Filters will not Run

Comcast does not write their own email, address book or calendar software.  The address book and calendar are provided by an affiliate called Plaxo.  The email is actually from Zimbra,




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: Email Filters will not Run

Thank you for clarifying my assumption that it is 3rd party.  There would most likely be huge implications and risks with requesting a functionality/bug fix change of this nature as Comcast would have to coordinate that with the 3rd party vendor.  It would realistically have to wait until some other planned and justified large-scale rollout/release of email functionality.  I can live with my workarounds. 

Email Expert

Re: Email Filters will not Run

What many of us recommend is that if you can't get the Comcast email UI features to work right for you------------enable the account in a real email client like Windows Live Mail, Thunderbird, or something else.  Then use the filtering feature in the client.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: Email Filters will not Run

So far my filters are working.  I probably have not been using them long enough to encounter the filters randomly turning themselves off.  I realize that this thread is focused on the inability to use the "run filter" option - and my issue was more with the inability to effectively edit filters with multi-line criteria and possibly multi-line actions.  My reasonsing behind wanting the filtering to occur on the Comcast server is the following:

 

Consider the scenario where an email user has multiple devices (Macs, PC's, iphones, other phones, iPad, etc).  Each of those devices has some type of mail client - which can probably implement some type of incoming mail filters.  An exception is iOS devices (iphone, iPad) that do not currently support mail filtering on the client side.  Those devices would access the Comcast mail server (assuming an IMAP Setup) - and pull the mail down into the client inbox - where no filtering would take place - defeating the primary purpose of filtering.

 

Should a filter then run on another device that supports filtering - the iOS device may or may not update the unfiltered mail immediatly - leading to a confusing view of the inbox.  The same would be true of various desktops and laptops that don't necessarily implement filtering or that don't implement it in a consistent manner.  In the mixed and matched client device scenario - where the clients are performing the filtering - it would almost be necessary to have one mail client running constantly on a desktop PC or Mac to attempt to pre-filter incoming mail for the other devices.

 

My preference would be to filter as much as possible using the Comcast filtering (where feasible) - because the filtering takes places when the external mail hits the comcast mail server - and client devices see only the filtered mail (regardless of whether the client device supports filtering) and then each device is almost guaranteed to have a consistent view of the filtered condition of their email.  I'm not seeing that Comcast's filtering is any better or worse than other major email service providers - it's just that that it would be nice if the UI worked as it was intended.

New Poster

Re: Email Filters will not Run

Email filters DO NOT RUN.  After I create one, which doesn't have the RUN NOW option, I have no idea how to execute it.  Has anyone ever been able to do this?  Looks like it has been an issue for several years.

Regular Visitor

Re: Email Filters will not Run

They have not "run" for a very long time.  They did at one time years ago.

New Poster

Re: Email Filters will not Run

The only way to filter some of these messages, esp the Romania ones is to set a new filter rule and the parameters have to be

 

Header Named: Received  Contains a.ro

 

Create entries for all letters of the alphabet using this pattern, then set everything to Discard.

 

Yes, it is a major pain, but Blocking Just Viral in the From field will not work because they get around that trap by writing in code.

Click on one of the Just Viral messages, right click, and select View Source from the pop-up menu. You will see what I mean.

 

There are other methods for other tricks the spammers use.