Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,809,572

members

26

online now

1,954,982

discussions

Top

EMAIL not receiving/sending

Regular Contributor

EMAIL not receiving/sending

Well looks like the "NEW" email format (changes) have borked the ability to send or receive emails.  I can not send or receive any emails on all of the emails under my account.  I sent several emails from my work account (not comcast/xfinity) to confirm and well you guessed it.  Nothing coming thru to Outlook or even to the NEW ugly Comcast (xfinity) Web Mail.

 

Stop making UGLY changes and messing up things that are working.  Please fix this issue.

Contributor

Re: EMAIL not receiving/sending

Same here. I'm sending emails (and bcc myself), and I'm not receiving the emails I bcc'd myself on. Little doubt that emails from other entites have been sent to me and I'm not receiving them. This is happening on the webmail as well as the Xfinity mobile app.

 

This is a recurring theme with this "new" email system!

Silver Problem Solver

Re: EMAIL not receiving/sending

See this general thread I started:

http://forums.xfinity.com/t5/Email-Web-Browsing/Comcast-mail-server-problems-the-past-few-weeks/m-p/...

 

I don't think the webmail interface change is a direct cause, although I do wonder if it's doing something that is overloading the actual mail servers. I only started having problems after being moved to the new webmail.