Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,808,152

members

77

online now

1,954,025

discussions

Top

E-mails

New Poster

E-mails

I am sending e-mails to people but they are not being received. No error or failed to send message is showing up. when I go to my sent box ist says they were sent

Email Expert

Re: E-mails

Are all your recipients at the same domain?  If so there may be a blocking issue at their end.  You could try calling Comcast security and see if they are aware of any problems-------------------

 

Comcast Customer Security Assurance-------------------

Normal business hours (6:00 am to 2:00 am EST, 7 days a week)

1 - 888-565-4329




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon