Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,806,148

members

18

online now

1,952,324

discussions

Top

E-mail

ANSWERED
New Poster

E-mail

I can send e-mail to other addresses but I cannot receive e-mail from myself or any other address.

Accepted Solution

Re: E-mail

Are you using only the Comcast webmail, or a client like Outlook or Thunderbird? One thing to check------------

Assuming that you are in either your Primary, or an unrestricted Secondary account, check to see if your "Safe List" is enabled--------------

Click on either "Account" or My Account" at the top of your screen, depending on which page you are on at the moment. It should ask you to sign in again. When you have done so, it should take you to a page with four tabs at the top that say "Overview", "Billing and Payments", "My Services", and "Users and Preferences". Click on "Users and Preferences" if it's not open already, and you should see another page with your name and address, account number and other things. You should see two tabs----"Basic Settings", and to the right of it ------"Email Settings". Click on that and you will see several choices including the Safe List. If it's enabled the button will be green.

When the Safe List is enabled, the only emails that will go to your Inbox will be from addresses or domains you deliberately put on that list manually. Nothing else will get through. So if it's turned on, you need to turn it off. It has been known to become enabled by itself, with no action on your part.

View answer in context
Email Expert

Re: E-mail

Are you using only the Comcast webmail, or a client like Outlook or Thunderbird? One thing to check------------

Assuming that you are in either your Primary, or an unrestricted Secondary account, check to see if your "Safe List" is enabled--------------

Click on either "Account" or My Account" at the top of your screen, depending on which page you are on at the moment. It should ask you to sign in again. When you have done so, it should take you to a page with four tabs at the top that say "Overview", "Billing and Payments", "My Services", and "Users and Preferences". Click on "Users and Preferences" if it's not open already, and you should see another page with your name and address, account number and other things. You should see two tabs----"Basic Settings", and to the right of it ------"Email Settings". Click on that and you will see several choices including the Safe List. If it's enabled the button will be green.

When the Safe List is enabled, the only emails that will go to your Inbox will be from addresses or domains you deliberately put on that list manually. Nothing else will get through. So if it's turned on, you need to turn it off. It has been known to become enabled by itself, with no action on your part.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: E-mail

Turning off the safe list worked.  Thanks.