Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,805,765

members

59

online now

1,952,107

discussions

Top

Connecting via KMail/Kontact

New Poster

Connecting via KMail/Kontact

I managed to make KMail work with Comcast, and thought I'd leave directions here for those who might need it (i.e, me when I set up a new computer, maybe somene else). I would have added it to the thread dedicated to customer-generated client settings, but I didn't see a "Reply" button there . Sorry if this new thread breaches protocol.

 

I'm using KMail version 4.14.10, so something may change in the future, but I've been using KMail for at least 10 years and the interface for creating a new account has stayed pretty consistent, as I recall. (Unlike the rest of KDE. )

 

1) In the menu bar, click Settings->Configure KMail...

 

2) Click on "Accounts", on the left hand side. (image below)

 

3) Click on the tab labeled, "Sending". You won't yet a "Comcast" entry yet; that's what we're here for. Smiley Happy

4) Click on the button labeled, "Add..." and a popup appears.

 

5) Give it an appropriate name ("Comcast SMTP" in the snapshot) and select "SMTP" in the list.

6) A new popup appears, titled "Configure account -- Kontact". For "Outgoing mail server," enter "smtp.comcast.net". Click the button, "Server requires authentication", and type your username and password. Be sure to use only your username, not "@comcast.net" or anything else of that sort. (That messed me up a while tonight.)

7) Click on "Advanced". Choose "TLS" encryption, Port 587, with LOGIN Authentication.That does the trick for me.

Gold Problem Solver

Re: Connecting via KMail/Kontact

The images you posted are only visible as a triangle inside a square. You may be able to see them, but others cannot.

New Poster

Re: Connecting via KMail/Kontact

Looks as if Comcast dropped the images after a while; it worked at first. Sorry. They're not necessary to follow the directions.