Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,807,342

members

5

online now

1,953,180

discussions

Top

Comcast site locks up

New Poster

Comcast site locks up

The Comcast home page locks up all the time. I can surf anywhere else with no problems. I close the main page as soon as I enter my Email acount so it will not lock up IE. Even doing the crossword puzzle linked to the main page will lock up IE. Very frustrating.

Email Expert

Re: Comcast site locks up


Try clearing out your browser's cache/browsing history. When you have done that, close out the browser and re-start it in a fresh session.

If that doesn't do it, then try using a different browser and see if you can duplicate the problem that way.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: Comcast site locks up

IE is set up to clear history every time I exit. The lock happens only on the Comcast pages.

Contributor

Re: Comcast site locks up

Can you explain why this ONLY HAPPENS ON X1 / COMCAST and I need to clear the History and Cache?

 

Why is it a MAJOR ISSUE HERE ON COMCAST ONLY?

 

You know I have asked this question of Comcast for years and have yet to ever recieve a reason why?

New Poster

Re: Comcast site locks up

Can I expect any real help from "Comcast" on this or will it just bounce around in this Forum?