Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,705,306

members

32

online now

1,869,100

discussions

Back to Top

Comcast Email on android Samsung Galaxy S III on AT&T

Posted by
New Poster
  • Congrats on Posting your first topic!

Message 1 of 14
10,319 Views

I am stumped... I set-up my comcast email on my Samsung GS3 which runs on the AT&T network...

 

The weird thing is that the messages are downloaded to my smartphone inbox, I can see them there when the arrive. After I view them, a few minutes goes by and they disappear!!!. No where to be found on the device. Not in any of the mail folders, not anywhere, nada...

 

I can't figure out why this is happening... The AT&T people have no clue either, and I have not been able to find this issue on the net anywhere... Wondering if I can resolve this here...

 

I used the incoming settings and outgoing settings as follows:

 

Incoming Settings:

Username

Password

Pop3 server: mail.comcast.net

Security Type: TLS

Port: 110

Delete email from server: When I delete from Inbox

 

Outgoing Settings:

SMTP server: smtp.comcast.net

Security Type: TLS

Port: 25:

Require Sign-in: box is checked

Userrname

Password

 

 

 

13 REPLIES
Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 2 of 14
9,392 Views

Dear "Mister"

I have exactly the same issue with my new Galaxy S III purchased last week. I see there are no responses to your post. Have you found a solution to the problem. All my settings are the same as my Droid 3 and the emails remained on that phone until I deleted them. I tried to uninstall and reinstall the account and the same thing happens. I uninstalled my "other" Comcast email account and installed the "Xfinity connect" client and didn't even get most emails and when I did, they'd disappear just like the Comcast "other" setup.

 

Posted by
Networking Expert

Message 3 of 14
9,383 Views

I have S3's on both the AT&T network and the Verizon network. I set up a secondary Comcast account to test this, and allowed the email client to detect the Comcast settings for email automatically, which  it did successfully. One phone I have set up to delete emails from the server when deleted from inbox, and one to never delete..

 

I then sent an email from another account to this one, and the email was received on both phones. I deleted the email from the phone which had 'delete from server when deleted from inbox' configured, and the email was removed from the server, AND from both phones. This would indicate that you may have another mail client set up to retreive mail fromn the Comcast server, and it is set up to delete emails from the server once it downloads them. Do you have a mail client set up on a computer to do this?

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

I don't work for Comcast...


Help us to help you!!
- respond to requests for info
- post back if your issue is resolved
- mark appropriate posts as solutions


Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 4 of 14
9,381 Views

Thank you kevj for your reply.

I did check my settings on my PC account and there was no check on the "leave copy of message on server" so I checked it and also checked the box "Remove from server after 30 days".  Perhaps this will work. I'll monitor the phone messages and get back.

Again, I appreciate your response. I was almost ready to turn in the phone but knew it had to be "user error' somewhere. Verizon suggested that I install the Xfinity app and that would take care of it. It did the same thing so I think you have the answer.

Thanks so much.

Tom

Posted by
Networking Expert

Message 5 of 14
9,377 Views

No Problem...stop back and let us know if it was the cause of the issue.

 

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

I don't work for Comcast...


Help us to help you!!
- respond to requests for info
- post back if your issue is resolved
- mark appropriate posts as solutions


Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 6 of 14
9,368 Views

Hello again kevj,

So far, so good. I've been getting emails regularly and they've stayed on the phone even after refreshing. I have found another issue (hoping this is the last one). I am unable to send or forward messages ("failed") and when I try to send or forward I get the message "Server unavailable-Comcast). I've checked the settings for the outgoing server

smtp.comcast.net  

Security type - None

Port 587

No check in "Require sigh in

 

Comparing to my previous setup on my Droid 3 (which worked well)

smtp.comcast.net

No check mark in "use secure connection"

Use secure password (TLS)  Dropdown choices - Never, Auto, Always   Chose - Auto

Authentication: Dropdown choices - None, Auto, MDS                             Chose - Auto

No check in "Verify Certificate"

 

If I choose SSL the port defaults to 465

If I choose TLS or None the port defaults to 587.

 

If it's not one thing, it's another.

Perhaps I should try whatever outgoing settings you have on your S III. Do you think that would work?

I'll try anything.

Thanks again

 

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 7 of 14
9,367 Views

I should add that, in checking email folders on the phone, all "failed" messages are sitting in the "Outbox" folder.

Thanks again and again.

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 8 of 14
9,363 Views

Dear kevj

I have been playing around with the outgoing settings on the phone and manually entered port 25 and No security.  It worked!!  I'm now sending and forwarding and receiving messages just like the olden days.

I appreciate your help. Sometimes it just takes someone to pass along an idea and it gets the mind working a bit. I'm hoping it keeps on working.

Thanks again.

raydeeo

Posted by
Networking Expert

Message 9 of 14
9,361 Views

Good stuff...glad to help.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

I don't work for Comcast...


Help us to help you!!
- respond to requests for info
- post back if your issue is resolved
- mark appropriate posts as solutions


Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Gold Problem Solver

Message 10 of 14
7,655 Views
Posted by
New Poster
Message 11 of 14
4,324 Views

OOOOOOHHHH I could kiss you right now!  I have been going around in circles for hours trying to set up my email accounts in my new Galaxy S5 and nothing was working....until I saw your post.  OMG  HALLELUJAH!  It worked!  I checked email client in my computer and it was set up to delete email from the server.  I changed that setting and now it works!!!!!

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 12 of 14
4,315 Views

MarfaO

So glad your email is working properly now. This stuff can drive you crazy!


MarfaO wrote:

OOOOOOHHHH I could kiss you right now!  I have been going around in circles for hours trying to set up my email accounts in my new Galaxy S5 and nothing was working....until I saw your post.  OMG  HALLELUJAH!  It worked!  I checked email client in my computer and it was set up to delete email from the server.  I changed that setting and now it works!!!!!




Posted by
New Poster
Message 13 of 14
4,303 Views

I have called several times over the last year in reference to the same issue it has yet to be fixed.  Our main email address _____@comcast.net has not worked in the last year on either of our electronic devices, I phone, Google nexus tablet, Samsung IV phone, Samsung II or III phone, and Ericson phone, logging in to the website itself is fine but being able to set it up on any electronic device as my main account does not work. We have 2 other Comcast emails that work just fine this is the fourth ticket that I'm opening up with Comcast and the issue has yet to be resolved.  If somebody can please give me a any suggestions to help me and fix my Comcast email.

[PC]

Error on electronic devices are: can not locate server

Error on gmail add as a pop 3:     There was a problem connecting to pop3.comcast.net

or it states connecting to server for ever before times out...

 

 

Manuel setup is as follows:

I used the incoming settings and outgoing settings as follows:

 

Incoming Settings:

Username

Password

Pop3 server: mail.comcast.net

Security Type: TLS

Port: 995

I am never able to gey to the out going set up

 

Outgoing Settings:

SMTP server: smtp.comcast.net

Security Type: TLS

Port: 587:

Require Sign-in: box is checked

Userrname

Password

 

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 14 of 14
3,070 Views