Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,807,773

members

80

online now

1,953,683

discussions

Top

Cant get emails since loading windows 10

Regular Visitor

Cant get emails since loading windows 10

i just (Oct 25, 2015) loaded windows 10..  now i cant get my comcast emails... allows me to log in, then i get a white screen with swirling blue dots; no emails load. what do i do? thanks. 

Service Expert

Re: Cant get emails since loading windows 10


dbohrman wrote:

i just (Oct 25, 2015) loaded windows 10..  now i cant get my comcast emails... allows me to log in, then i get a white screen with swirling blue dots; no emails load. what do i do? thanks. 


Are you using WIndows10's EDGE browser with webmail or with an email client?

 




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Regular Visitor

Re: Cant get emails since loading windows 10

Thank you. I'm sorry but I am not sure what those terms mean.  I use Edge the way it came with Windows 10.  To get my emails, I go to the internet via Edge, search for comcast, log in to comcast, and select email.

 

However, I just tried it again right before i am replying to you and my email loaded in Edge.  It did the blue-swirling dot thing for 10 seconds maybe, then loaded the emails. Tried it again, worked again.  Then tried the same thing except went to comcast via Chrome. Got the blue swirling dots only; waited a minute or two, but the emails never loaded.

 

Thanks, DB

Service Expert

Re: Cant get emails since loading windows 10


dbohrman wrote:

Thank you. I'm sorry but I am not sure what those terms mean.  I use Edge the way it came with Windows 10.  To get my emails, I go to the internet via Edge, search for comcast, log in to comcast, and select email.

 

However, I just tried it again right before i am replying to you and my email loaded in Edge.  It did the blue-swirling dot thing for 10 seconds maybe, then loaded the emails. Tried it again, worked again.  Then tried the same thing except went to comcast via Chrome. Got the blue swirling dots only; waited a minute or two, but the emails never loaded.

 

Thanks, DB


Fantastic!  if EDGE is working for you then stick with it!

 

Ray




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon