Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,638,714

members

9

online now

1,816,252

discussions

Back to Top

Cannot setup email account on Samsung Galaxy S3

Posted by
Visitor
  • Congrats on Posting your first topic!

Message 1 of 5
22,394 Views

I am trying to add two existing Comcast email accounts to a new Samsung Galaxy S3 cell phone. I have followed the steps to manually configure using the following information:

 

Account Name & password

Type of Account: POP3

User Name: My account name
Password: My password 

POP3 server: mail.comcast.net

Security type: SSL

Port: 995

 

I have also tried using:

User name: My account name followed by @comcast.net

Security type: SSL (Accept all certificates)

Port: 995

 

And:

Seciruty type: None

Port: 110

 

None of these settings will work. I receive the error message with any type of confirguation: Unable to connect to server

4 REPLIES
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 2 of 5
22,152 Views
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 3 of 5
21,959 Views

Hello, I had the same problem but this worked for me.

 

Enter your name and your password then enter the following in the appropriate spaces:

 

Pop3 Server: mail.comcast.net

Security Type: SSL

Port # 995

Outgoing Server: smtp.comcast.net

Security Type: SSL

Outgoing Port: 465

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 4 of 5
20,890 Views

This does not work on my Galaxy S3. I have tried all configs and I keep getting "Server does not support authentication" for outgoing server.

Posted by
Gold Problem Solver

Message 5 of 5
20,849 Views

Maybe try using 587 without SSL for smtp port.



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.