Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,636,982

members

57

online now

1,814,808

discussions

Back to Top

Cannot just open a Microsoft Word attachment - must download it first. Why?

SOLVED
Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!
  • Great Job! Your reply has been accepted. Thank you for helping and Congrats on your 1st Solution.

Message 1 of 10
5,208 Views

Used to be I could click on an attachment in an email and open it with the appropriate program. Now I am forced to save the item (to my hard drive or whatever) first, then open it. Can I change a setting somewhere so that this is not necessary?

9 REPLIES
Posted by
Gold Problem Solver

Message 2 of 10
5,205 Views

 


annetheresa wrote:

Used to be I could click on an attachment in an email and open it with the appropriate program. Now I am forced to save the item (to my hard drive or whatever) first, then open it. Can I change a setting somewhere so that this is not necessary?


 

What error are you gettting (if any) when trying to open the attachment?

 

Look in Control Panel> Folder Options> File Types to see what is showing there as the default program used to open these type of files.  I assume they are .doc files?



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!
  • Great Job! Your reply has been accepted. Thank you for helping and Congrats on your 1st Solution.

Message 3 of 10
5,201 Views

I don't get any error message; when I right-click and choose "open in a new tab" my computer opens a dialog box entitled "enter name of file to save to." ( I am using Mozilla Firefox as my browser) I don't see an option to simply open the file without first saving it. Is this a browser issue? If so, why would it just start happening?

Posted by
Gold Problem Solver

Message 4 of 10
5,198 Views

Do you see the name of the attachment in the email, followed by 'Download" or Remove?  (see sample below)

If yes you see the file name, what happens if you click on the name of the attachment?  (NOT right-click, just click on the file name)Does another window open?  it could also be a setting in FF.  Under Tools> Applications, can you locate Microsoft Word in the Content Type?  Next to Word, there should be a drop-down box with choices to always ask before opening, to save the file, etc.

What do you see?


 




Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!
  • Great Job! Your reply has been accepted. Thank you for helping and Congrats on your 1st Solution.

Message 5 of 10
5,528 Views
Solution

Yes, I do see the options of "Download" and "Remove" as in your example. When I click on "Download" a pop-up window opens with that dialog box i mentioned (the one that only permits me to save the doc, not open it directly)....

OK, it was a browser issue. I just followed your directions in Firefox: (Tools - Options - Applications - [scroll down to] Microsoft Word). It was set to "Save File" rather than "Open with Microsoft Word." I made the change to "Open..." and now all is well.

Thanks so much. How this setting got changed originally is beyond me. I do appreciate your help solving the problem.

 

Posted by
Gold Problem Solver

Message 6 of 10
5,191 Views

It might have been a glitch in the latest upgrade FF made, (FF 4.1) OR you may never know what happened.  Glad it worked out for you in any case!

CC



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Posted by
Frequent Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 7 of 10
4,908 Views

I also Cannot just open a Microsoft Word attachment - must download it first then open it.

I use OpenOffice Writer, Internet Explorer 9, Xfinity Connect (full), no email client, MS Windows-7 Pro 64-bit PC.  I do not use FireFox.

Posted by
Gold Problem Solver

Message 8 of 10
4,899 Views

guysyl wrote:

I also Cannot just open a Microsoft Word attachment - must download it first then open it.

I use OpenOffice Writer, Internet Explorer 9, Xfinity Connect (full), no email client, MS Windows-7 Pro 64-bit PC.  I do not use FireFox.


What is the file format of the MS attachment? 

 



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Posted by
Service Expert

Message 9 of 10
4,896 Views

Something else you can do.  Check your pop up blocker, it may be seeing the mail/attachemnt/link as a pop up.

If you are using the Internet Explorer pop up blocker included with Service Pack 2 or Service Pack 3
these instructions work with IE6, IE7 and IE8.

Go to Tools at the top of this page.

Internet Options/Privacy tab.

Click on Settings in Pop-up Blocker.

Add the following to the Allow line:

*.mail.comcast.net

Close out Internet Options, see if the  mail/attachemnt/link will open.

If you use a different blocker, just look on the bottom of the page to see if you get a notification that one has been blocked when you click on the message. If you do, you can usually click the notification icon and will be able to allow pop ups from *.mail.comcast.net

Post back with the name of the one you use if you can't figure it out, and someone will help you.

I think I saw something in this forum about ctrl or shift key while clicking on the message would not over-ride a popup blocker.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 10 of 10
4,889 Views

After I submitted my problem to you, I tried another trick:

Selected a typical OO Writer file from My Documents folder and right-clicked on it, then selected Open With and chose OpenOffice from the list. I check the box marked Always use the selected program to open this kind of file. This solved my problem of opening an attached text doc directly without having to download it. Now, all I have to do is click on the email attachment and hit Open or Save in the next window.

 

Thanks for the advice guys.