Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,683,876

members

12

online now

1,852,191

discussions

Back to Top

AirPort and DNS Server

SOLVED
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 1 of 5
22,485 Views

Quick question:

Which is a better setting with Airport Exteme setup:

"Share A Public IP Address" or "Distribute A Range of IP Addresses" and why?

The reason for the question is I sometimes have issues with connecting wireless devices to the AirPort involving DNS server recognition while "Share A Public IP Address" is enabled.

 

 

4 REPLIES
Posted by
Networking Expert

Message 2 of 5
22,471 Views

It depends on your situation and network environment.  If you are like most residential users and your Airport Extreme is your primary or only router, then the only correct option to use is Share a public IP address.  This sets up the AE to get the one public IP address from Comcast and provide private IP address to your local systems and pass things back and forth through a NAT layer to the outside world only sees the public IP even though the requests are from your systems with private IP addresses.

 

You use the Distribute a range of IP addresses option when you have a situation where Comcast is providing you more than one public IP address or you have a complex local LAN setup with different subnets, etc.

 

Perhaps if you were to describe these "DNS server recognition" issues, we might be able to help.  Be as specific as possible, OS'es involved, AE setup, TCP/IP config on connected systems, etc.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 3 of 5
22,443 Views

Hello Baric,

 

Thank you for your interest. The reason for the inquiry is I have always had to manually supply the DNS numbers. I have five wireless clients and one wired client connected to my Airport. Here’s the run down:

 

1 x wired iMac:

OS 10.6.8

iPv4: 192.168.1.4

Subnet Mask: 255.255.255.0

Router: 192.168.1.1

DNS Servers: 68.87.71.230, 68.87.73.246

 

1 x wireless Macbook:

OS 10.5.8

iPv4: 192.168.1.12

Subnet Mask: 255.255.255.0

Router: 192.168.1.1

DNS Servers: 68.87.71.230, 68.87.73.246

Server Domain: hsd1.ma.comcast.net.

 

1x wireless iPod(4th generation)

iOS 5.0.1

IP Address: 174.62.138.185

LAN IP Address: 192.168.1.1

Router Address: 174.62.138.1

DNS Server: 10.0.1.1

DNS Server: 75.75.76.76

 

1 x wireless Samsung BlueRay Player:

 iPv4: 192.168.1.7

Subnet Mask: 255.255.255.0

Router: 192.168.1.1

DNS Servers: 68.87.71.230

 

1 x wireless Xbox:

iPv4: 192.168.1.2

Subnet Mask: 255.255.255.0

Router: 192.168.1.1

DNS Servers: 68.87.71.230

 

1 x wireless Onkyo Reciever

iPv4: 192.168.1.9

Subnet Mask: 255.255.255.0

Router: 192.168.1.1

DNS Servers: 68.87.71.230

*Lost wireless connection recently and have not been able to reconnect (this happened before trying to connect the Dell)

 

1 x wired Dell Optiplex 520GX with Windows 7:

I have recently tried unsuccessfully to connect to the Airport via the Ethernet port and continually get a dialogue box stating "DNS Server not found or connection failed". I have followed Comcast’s suggested Windows 7 settings for configuration but to no avail. When I get a chance I am going into Command Prompt and Release and Renew the IPConfig settings. Perhaps this might help.

 

Airport Extreme:

Version 7.6 (up to date firmware)

Configure IPv4: Using DHCP

IP Address: 174:62:138:185

Subnet Mask: 255.255.255.0

Router Address: 174.62.138.1

DNS Server: 10.0.1.1

Domain Name: Blank

DHCP Client ID: Blank

Under the “Internet Connection” Tab

“Connection Sharing”

                        “Share a public IP address”

Please note: I recently discovered under the “NAT” Tab, the “Enable default host at” is unchecked and the field is also blank. Since NAT allows you to share a single public IP address with computers and devices on the network, my guess is the field should be enabled and the blank field filled in?

 

I have always had to provide the DNS server addresses 68.87.71.230 and 68.87.73.246 manually following the notification of the "Connection to the DNS Server failed" dilaogue box to each of the devices except to the iPod.

 

Any suggestions and advice would very much be appreciated.

 

Thank you again for your time and effort!

Posted by
Email Expert

Message 4 of 5
23,364 Views
Solution

You only need to fill in the default host if you're running a server on your LAN. This tells the router to forward all incoming connections to that IP. It's not needed for normal use, where you initiate connections from machines on your network. The router automatically passes the return traffic to the appropriate machine.

 

It looks like the problem you're having is that you've manually configured the DNS server on the Airport to 10.0.1.1. That's not a valid DNS server IP. Leave that blank, and let the Airport get its DNS from Comcast, and it should pass this along to the clients on the LAN.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 5 of 5
22,155 Views

Hello Barmar,

 

Thank you for your suggestion! It worked! I had to wire my Onkyo directly to the AirPort. Apparently, there's a separate issue going my Onkyo wireless LAN adapter. Otherwise, all clients wireless and wired are connected and are receiving the new DNS IP address. Thank you for your time!