Welcome to Comcast Help & Support Forums
You can contribute an answer or post a question.
Reply
Posted by
Visitor
  • The Community would like to Welcome you!



Member Since: ‎01-26-2012
Posts: 1

Why is my E-mail so slow?

How do I find out what makes my E-mail slow & unusable ? 

Posted by
Email Expert



Member Since: ‎05-21-2006
Posts: 29,369

Re: Why is my E-mail so slow?

[ Edited ]

Mickey85 wrote:

How do I find out what makes my E-mail slow & unusable ? 



Please answer all the following questions:

 

Do you XfinityConnect?  The Full or the Lite version?

Do you use an email client?  Which one?  ( Eg:  Windows Mail, Outlook,etc.)

Which browser and version do you use?

Have you cleared your browser cache?  If not, please do so.

Have you tried another browser?

Have you run a virus scan of your PC?

 

What happens exactly after you sign on and try to go to Email?

CC

 



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Posted by
Visitor
Member Since: ‎11-16-2008
Posts: 1

Re: Why is my E-mail so slow?

My email has become so slow that it is almost unuseable. The computer is fine with everything else and had been fine until about 2 weeks ago.I am looking for an answer also.

Posted by
Email Expert



Member Since: ‎05-21-2006
Posts: 29,369

Re: Why is my E-mail so slow?


taffy21 wrote:

My email has become so slow that it is almost unuseable. The computer is fine with everything else and had been fine until about 2 weeks ago.I am looking for an answer also.


 

Please answer the questions in my previous post. (scroll up)

CC



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.