Welcome to Comcast Help & Support Forums
You can contribute an answer or post a question.
Reply
Posted by
New Visitor
  • The Community would like to Welcome you!
Member Since: ‎05-02-2012
Posts: 1

Outlook email settings -where/what are they?

I am in a loop on Comcast's site to try to find the email account settings for POP3 and SMTP as well as my correct domain name for my comcast email accounts that I just set up.  Can anyone help with these settings?  The FAQ are useless.

 

Thank you!

Posted by
Silver Problem Solver
Member Since: ‎02-22-2007
Posts: 6,127

Re: Outlook email settings -where/what are they?

Posted by
Email Expert
Member Since: ‎05-21-2006
Posts: 29,241

Re: Outlook email settings -where/what are they?

That is a very old link:  See this one:

 

http://forums.comcast.com/t5/E-Mail-and-Xfinity-Connect-Help/E-Mail-Client-Settings-customer-generat...



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Posted by
Official Employee
Member Since: ‎03-17-2008
Posts: 840

Re: Outlook email settings -where/what are they?

The FAQ was actually just updated last week.  Check it out: http://customer.comcast.com/help-and-support/internet/email-client-programs-with-xfinity-email/

Posted by
Email Expert
Member Since: ‎05-21-2006
Posts: 29,241

Re: Outlook email settings -where/what are they?


ComcastJordan wrote:

The FAQ was actually just updated last week.  Check it out: http://customer.comcast.com/help-and-support/internet/email-client-programs-with-xfinity-email/


Jordan,

What happened to the alternative port for smtp of 587 without SSL? 

Carole



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.