Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.




online now



Error receiving email in Outlook 2003 '0x8004210A'

Posted by
Regular Visitor
Member Since: ‎01-31-2007
Posts: 3
Message 1 of 5 (3,089 Views)

Error receiving email in Outlook 2003 '0x8004210A'

We have 2 pcs both running outlook 2003 with no problems until Tuesday am when we got the receiving error 0x800421A when outlook tries to receive our incoming mail.  Of course we can see our mail on Comcast web mail but cannot receive it in outlook any longer.   We have checked our configuration, disabled both our virus protection (Mcaffee) and our firewall, but still we are timing out trying to receive our mail.  Any help would be greatly appreciated.
Posted by
Most Valued Poster

Member Since: ‎10-01-2003
Posts: 14,085
Message 2 of 5 (3,079 Views)

Re: Error receiving email in Outlook 2003 '0x8004210A'

Try the following:
In Outlook 2003:
  1. choose Tools
  2. choose E-mail Accounts
  3. choose "View or change existing e-mail account"
  4. choose Next
  5. click on your Comcast account to highlight it
  6. choose Change
  7. enter Your Name (whatever you want to appear on your messages)
  8. enter E-mail Address (your full Comcast email address)
  9. Incoming mail server is mail.comcast.net
  10. Outgoing mail server is smtp.comcast.net
  11. enter User Name (your Comcast user ID, the part before "@comcast.net" in your email address)
  12. enter Password
  13. check "Remember password"
  14. make sure “Logon using Secure Password Authentication (SPA)” is NOT checked
  15. choose More Settings
  16. go to the Outgoing Server tab
  17. check “My outgoing server (SMTP) requires authentication”
  18. choose “Use same settings as my incoming mail server”
  19. go to the Advanced tab
  20. check both boxes for “This server requires an SSL-secured connection”
  21. change port number to 465 for outgoing, 995 for incoming
  22. bump up the Server Timeouts slider to the high end
  23. Click OK, Next, Finish

Turn off whatever email scanning your anti-virus package is doing. Comcast already scans incoming email for viruses, and your outgoing email isn’t going to be infected unless your machine is already infected, so there’s no point checking it all the time.

Don't bother with the "Test" function in Outlook - it often fails for no particular reason.

Exit from Outlook, then make sure it isn't still running in the background. Hit CTRL-ALT-DEL, go to the Processes tab, and kill any occurrences of OUTLOOK.EXE before launching Outlook again.

If none of that cures the problem, my advice is to remove McAfee completely, and use some less intrusive security software.  McAfee seems to have turned into the new "Norton" - protecting your PC by preventing you from using it for anything.

Posted by
Regular Visitor
Member Since: ‎01-31-2007
Posts: 3
Message 3 of 5 (3,045 Views)

Re: Error receiving email in Outlook 2003 '0x8004210A'

It all works now!  I found the secure port numbers by searching the forum before I got your post and was able to receive mail after changing them but still had problems sending.  Somehow the outgoing server authentication was not checked, and after doing that sending works too.  Thanks for the specific instructions, they were right on the money.
Posted by
Member Since: ‎02-03-2007
Posts: 1
Message 4 of 5 (3,021 Views)

Re: Error receiving email in Outlook 2003 '0x8004210A'

Thank you,  this procedure works!   I had everything right except the outgoing port.
Posted by
  • The Community would like to Welcome you!

Member Since: ‎03-14-2011
Posts: 1
Message 5 of 5 (2,929 Views)

Re: Error receiving email in Outlook 2003 '0x8004210A'

Worked for me too.  Thanks!