Welcome to Comcast Help & Support Forums
You can contribute an answer or post a question.
Reply
Posted by
New Visitor
Member Since: ‎09-19-2012
Posts: 1

Email not loading/receiving on my iPhone & iPad for 3 days now!

Email not loading/receiving on my iPhone & iPad for 3 days now!
Posted by
New Visitor
Member Since: ‎10-31-2010
Posts: 1

Re: Email not loading/receiving on my iPhone & iPad for 3 days now!

I am having the same issue - can not reply to e-mails that do make it through

Posted by
New Visitor
Member Since: ‎09-21-2012
Posts: 1

Re: Email not loading/receiving on my iPhone & iPad for 3 days now!

My e-mail to my Mac laptop has stopped working since 9/7/12.

 

On my I-pad, I am receiving e-mail but cannot reply or forward. Prompt keeps saying password is wrong.

I go to settings and keep re-entering same password but within minutes it forgets it.

Posted by
Web Page Expert
Member Since: ‎11-14-2006
Posts: 6,340

Re: Email not loading/receiving on my iPhone & iPad for 3 days now!

There are multiple people posting about multiple devices here.

 

For the iPhone and iPad, check the settings in the screenshots I made here:

http://forums.comcast.com/t5/E-Mail-and-Xfinity-Connect-Help/Can-t-configure-Comcast-email-on-iPhone...

 

For the desktop, check the settings in the sticky note at the top of this email forum.

 

Check whether you can get mail through the Xfinity Connect website. 

 

If you change your password, you need to change it in mail (iPhone, iPad, or Mac mail) for both incoming and outgoing. You change it in two places.