Welcome to Comcast Help & Support Forums
You can contribute an answer or post a question.
Reply
Posted by
Visitor
Member Since: ‎10-04-2007
Posts: 2

Can't send comcast emails OUT

I have not been able to send email out from my comcast account for the past two days. I've checked my settings and don't think they've changed. Please advise!

Posted by
Silver Problem Solver
Member Since: ‎02-22-2007
Posts: 6,127

Re: Can't send comcast emails OUT

Hello,

For better helping you with your problem you will have to provide us a lot more details. What email client are you using? Are you getting any error message if so what does the exact error message? Any other more info you can provide would be helpful.

Posted by
Email Expert
Member Since: ‎05-21-2006
Posts: 29,140

Re: Can't send comcast emails OUT

Also do post which settings you are using.... For POP 3 and for SMTP.

Have you cleared your browser cache?  Which browser?

 

 



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Posted by
Visitor
Member Since: ‎10-04-2007
Posts: 2

Re: Can't send comcast emails OUT

Hi.......  I'm using the Mac Mail program for emails and using Safari as my browser.  The email account is set as follows:

 

 comcast.net.POP

Incoming Mail:  mail.comcast.net

Outgoing: smtp.comcast.net

 

I don't think this is different than it's been before...  just not sending out now. Still receiving incoming emails.  Thank you for some prompt assistance!  Many thanks.

 

The error message says:  "Cant send with selected server smtp.comcast.net." It then gives me the option to "Try later", "Try with selected Server" or "Edit Message."

Posted by
Web Page Expert
Member Since: ‎11-14-2006
Posts: 6,340

Re: Can't send comcast emails OUT

I also use Mac Mail. Sometimes it's just finicky and the handshaking didn't work. So I try again.

 

Sometimes the address is odd, so I usually check whether there's a missing .com or something.

 

Sometimes sending a message to myself nudges the mail server and things get going again.

 

If it doesn't work after a few minutes, you can check the mail settings and particularly the outgoing settings where you should set the port to 465 or 587 (choose one, not the default that may wander into 25). Click in front of SSL, set authentication to password and enter your username (without the @comcast.net) and your password. 

 

If you also have problems with incoming mail, set that port to 995, use SSL and password authentication. 

 

The password needs to be set in two places when you change it.