Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.








Billing -Issues

New Poster

Billing -Issues

Account signed up on the 18th of February. Self-install. The devices came and were installed correctly, However there was an issue with all Services since the date of activation. A tech was sent out on the 28th, (10 days after activation) to resolve TV pixelation issues. We were unable to watch the TV at all from the 18th until the 28th. This tech stated I would not be charged for the visit as there was an issue with the box. He replaced the splitter and box and TV pixelation Issues were resolved. I work from home. Internet service was not able to keep a good connection and I kept getting disconnected. Ping Tests indicated severe packet loss on Comcast side. Called in and another tech was sent out, he was unable to resolve the issues, and a line tech was called out for the next day, We are now at the 9th of March. Finally, after Line tech replaced some stuff at the pole and and the other tech replaced the line from the house to the pole on the 9th. Internet issues appear to have been resolved. Today, March 12th. I am working, 8:30 AM the Internet goes down. I am checking my account to see if there is an outage. There is a reported TV outage, but my Internet service was removed completely from my account, had to call in and another 45 minutes spent getting my modem re-activated so I can work. Also inquired as to why I was charged $60.00 for the first tech visit, when tech stated I would not be charged. CSR states he will apply a $20.00 credit to the account for the trouble, but $60.00 is standard charge for install within 30 days of service activation. I should not even be charged for the time from Feb 18th until the 28th for TV service and not for internet from at least Feb 28th until the 9th of March. I was unable to even use the services I signed up for, not to mention all of the trouble and time wasted due to issues with Comcast equipment and services not working properly. Very poor customer service. Would like my account at least credited with the $60.00 I was told I WOULD NOT be charged. 

Forum Changes:
Open Wifi Hotspots Northeast Division... See More
Discussion stats
  • 0 replies
  • 0 kudos
  • 1 in conversation