Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,682,145

members

68

online now

1,850,788

discussions

Back to Top

No sound on certain channels

SOLVED
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 1 of 17
25,729 Views

My TV has been workinng fine and I had sound on all channels.  As of 12/14/11, I now only get sound on some channels and on others I have sound with no problem.  Why is that and how do I fix the problem since obviously the TV works and the cable connection works since I get video on all channels and sound on some but not all.

16 REPLIES
Posted by
Cable Expert

Message 2 of 17
27,807 Views
Solution

If you have a DTA  try hitting the "LANG" button.  Otherwise, check the SAP (second audio program).




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 3 of 17
25,721 Views

Thank you.  It was the LANG button.  All works fine now.

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 4 of 17
24,897 Views

thanx!!  man that was driving me nuts...i'll remember that one Smiley Happy

 

Posted by
Frequent Visitor

Message 5 of 17
21,305 Views

I have a friend having this same issue - no sound on MTV, ABC Family and TLC.  She said it's only on the hookup in her bedroom.  All other TV's in the house have sound and no issues with these channels.  She has called Comcast and they've been no help.  Any suggestions?

Posted by
Cable Expert

Message 6 of 17
21,302 Views

Did your friend try the suggestion in post #2 by pressing the "LANG" button?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor

Message 7 of 17
21,297 Views

Yes, she did.  Did not help.

Posted by
Silver Problem Solver

Message 8 of 17
21,292 Views

Have her try the tv remote and cycling through the SAP/Language options on the tv itself.

 

Posted by
Cable Expert

Message 9 of 17
21,288 Views

Have her try the SAP button on the TV's remote control.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor

Message 10 of 17
21,268 Views

Thanks, I have passed on your info for her to try. 

Posted by
Frequent Visitor

Message 11 of 17
21,266 Views

Thanks!  I have passed on the info to my friend.  If her remotes are anything like ours, we do not have a LANG button or an SAP button on either our Comcast remote or TV remote, so would they be in the menu listing somewhere?  just curious!  We are not having any issues with sound, but I looked at our remotes for the LANG and SAP buttons and they aren't there.

Posted by
Silver Problem Solver

Message 12 of 17
21,256 Views

On my tv remote it is labeled MTS. I have a Samsung. The tv menu would be the other option.

Posted by
Frequent Visitor

Message 13 of 17
21,252 Views

Okay, thank you!  Our TV remote has the MTS button - maybe hers does as well.

Posted by
Frequent Visitor

Message 14 of 17
21,241 Views

Angie said she tried all your suggestions and she still does not have sound on certain channels.  If she hooks up another tv to the same cable she gets the same senario - no sound.  But all the tv's sound works in other rooms when they are hooked up, just not her bedroom. 

 

Any other ideas?  suggestions?

Posted by
Cable Expert

Message 15 of 17
21,235 Views

Have her take the box and remote to the local Comcast office for a swap.  Seems like you two have tried just about everything.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor

Message 16 of 17
21,233 Views

thank you for all your help and suggestions.  that's what I told her to do.

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 17 of 17
20,514 Views

Thanks!  Just started having sound problems on a few of the local broadcast channels and the LANG button fixed it.  How come the Comcast customer service person I spoke to for 15 minutes couldn't suggest this?  Why do customers have to search online for solutions to Comcast's service problems??