Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,514,414

members

51

online now

1,714,920

discussions

Back to Top

No sound on certain channels

SOLVED
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Member Since: ‎12-15-2011
Posts: 2
Message 1 of 17 (19,220 Views)

No sound on certain channels

My TV has been workinng fine and I had sound on all channels.  As of 12/14/11, I now only get sound on some channels and on others I have sound with no problem.  Why is that and how do I fix the problem since obviously the TV works and the cable connection works since I get video on all channels and sound on some but not all.

16 REPLIES
Posted by
Edited on
‎12-15-2011 11:50 PM

Cable Expert

Member Since: ‎12-31-2004
Posts: 10,676
Message 2 of 17 (21,298 Views)

Re: No sound on certain channels

[ Edited ]

If you have a DTA  try hitting the "LANG" button.  Otherwise, check the SAP (second audio program).




Community Icon
I am not a Comcast employee, I am a paying customer just like you! I am an XFINITY Forum Expert and I am here to help.To learn more about XFINITY Forum Expert program click here.
Was your question answered? Mark it as an accepted solution!solution Icon
Did this post help? Why not give it a kudo!!!Kudos Icon
Community Icon
I am not a Comcast employee, I am a paying customer just like you! I am an XFINITY Forum Expert and I am here to help.To learn more about XFINITY Forum Expert program click here.
Community Icon
I am an XFINITY Forum Expert and I am here to help. Expert Program
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Member Since: ‎12-15-2011
Posts: 2
Message 3 of 17 (19,212 Views)

Re: No sound on certain channels

Thank you.  It was the LANG button.  All works fine now.

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Member Since: ‎02-09-2012
Posts: 1
Message 4 of 17 (18,388 Views)

Re: No sound on certain channels

thanx!!  man that was driving me nuts...i'll remember that one Smiley Happy

 

Posted by
Frequent Visitor

Member Since: ‎10-12-2012
Posts: 12
Message 5 of 17 (14,796 Views)

Re: No sound on certain channels

I have a friend having this same issue - no sound on MTV, ABC Family and TLC.  She said it's only on the hookup in her bedroom.  All other TV's in the house have sound and no issues with these channels.  She has called Comcast and they've been no help.  Any suggestions?

Posted by
Cable Expert

Member Since: ‎03-02-2007
Posts: 17,739
Message 6 of 17 (14,793 Views)

Re: No sound on certain channels

Did your friend try the suggestion in post #2 by pressing the "LANG" button?




Community Icon
I am not a Comcast employee, I am a paying customer just like you! I am an XFINITY Forum Expert and I am here to help.To learn more about XFINITY Forum Expert program click here.
Was your question answered? Mark it as an accepted solution!solution Icon
Did this post help? Why not give it a kudo!!!Kudos Icon
Community Icon
I am not a Comcast employee, I am a paying customer just like you! I am an XFINITY Forum Expert and I am here to help.To learn more about XFINITY Forum Expert program click here.
Community Icon
I am an XFINITY Forum Expert and I am here to help. Expert Program
Posted by
Frequent Visitor

Member Since: ‎10-12-2012
Posts: 12
Message 7 of 17 (14,788 Views)

Re: No sound on certain channels

Yes, she did.  Did not help.

Posted by
Silver Problem Solver

Member Since: ‎01-11-2010
Posts: 5,625
Message 8 of 17 (14,783 Views)

Re: No sound on certain channels

Have her try the tv remote and cycling through the SAP/Language options on the tv itself.

 

Posted by
Cable Expert

Member Since: ‎03-02-2007
Posts: 17,739
Message 9 of 17 (14,779 Views)

Re: No sound on certain channels

Have her try the SAP button on the TV's remote control.




Community Icon
I am not a Comcast employee, I am a paying customer just like you! I am an XFINITY Forum Expert and I am here to help.To learn more about XFINITY Forum Expert program click here.
Was your question answered? Mark it as an accepted solution!solution Icon
Did this post help? Why not give it a kudo!!!Kudos Icon
Community Icon
I am not a Comcast employee, I am a paying customer just like you! I am an XFINITY Forum Expert and I am here to help.To learn more about XFINITY Forum Expert program click here.
Community Icon
I am an XFINITY Forum Expert and I am here to help. Expert Program
Posted by
Frequent Visitor

Member Since: ‎10-12-2012
Posts: 12
Message 10 of 17 (14,759 Views)

Re: No sound on certain channels

Thanks, I have passed on your info for her to try. 

Posted by
Frequent Visitor

Member Since: ‎10-12-2012
Posts: 12
Message 11 of 17 (14,757 Views)

Re: No sound on certain channels

Thanks!  I have passed on the info to my friend.  If her remotes are anything like ours, we do not have a LANG button or an SAP button on either our Comcast remote or TV remote, so would they be in the menu listing somewhere?  just curious!  We are not having any issues with sound, but I looked at our remotes for the LANG and SAP buttons and they aren't there.

Posted by
Silver Problem Solver

Member Since: ‎01-11-2010
Posts: 5,625
Message 12 of 17 (14,747 Views)

Re: No sound on certain channels

On my tv remote it is labeled MTS. I have a Samsung. The tv menu would be the other option.

Posted by
Frequent Visitor

Member Since: ‎10-12-2012
Posts: 12
Message 13 of 17 (14,743 Views)

Re: No sound on certain channels

Okay, thank you!  Our TV remote has the MTS button - maybe hers does as well.

Posted by
Frequent Visitor

Member Since: ‎10-12-2012
Posts: 12
Message 14 of 17 (14,732 Views)

Re: No sound on certain channels

Angie said she tried all your suggestions and she still does not have sound on certain channels.  If she hooks up another tv to the same cable she gets the same senario - no sound.  But all the tv's sound works in other rooms when they are hooked up, just not her bedroom. 

 

Any other ideas?  suggestions?

Posted by
Cable Expert

Member Since: ‎03-02-2007
Posts: 17,739
Message 15 of 17 (14,726 Views)

Re: No sound on certain channels

Have her take the box and remote to the local Comcast office for a swap.  Seems like you two have tried just about everything.




Community Icon
I am not a Comcast employee, I am a paying customer just like you! I am an XFINITY Forum Expert and I am here to help.To learn more about XFINITY Forum Expert program click here.
Was your question answered? Mark it as an accepted solution!solution Icon
Did this post help? Why not give it a kudo!!!Kudos Icon
Community Icon
I am not a Comcast employee, I am a paying customer just like you! I am an XFINITY Forum Expert and I am here to help.To learn more about XFINITY Forum Expert program click here.
Community Icon
I am an XFINITY Forum Expert and I am here to help. Expert Program
Posted by
Frequent Visitor

Member Since: ‎10-12-2012
Posts: 12
Message 16 of 17 (14,724 Views)

Re: No sound on certain channels

thank you for all your help and suggestions.  that's what I told her to do.

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Member Since: ‎11-29-2010
Posts: 2
Message 17 of 17 (14,005 Views)

Re: No sound on certain channels

Thanks!  Just started having sound problems on a few of the local broadcast channels and the LANG button fixed it.  How come the Comcast customer service person I spoke to for 15 minutes couldn't suggest this?  Why do customers have to search online for solutions to Comcast's service problems??