Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,724,765

members

80

online now

1,886,780

discussions

Back to Top

auto pay not working and gave me late fees

Posted by
Regular Visitor
  • Great Job! Your reply has been accepted. Thank you for helping and Congrats on your 1st Solution.
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 1 of 7
691 Views

Why on earth are you guys charging me a late fee when I have auto pay on with a valid credit card which auto pay has apprantly not been paying dispite being on what kind of scam is this. Is that not the point of auto pay set it to automaticly pay so you dont have to worry about paying not to mention it was auto paying just fine untill I upgraded my speed.

6 REPLIES
Posted by
Problem Solver

Message 2 of 7
632 Views

Hello Jyohan,

 

I will be more than happy to assist you with your billing concerns regarding the Auto Pay and late fee. I have sent you a private message so that we can discuss your concerns more freely.




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 3 of 7
519 Views

Having a constant issue with auto pay also, did not work last month, I resubmitted credit card info, same as previous card, valid card, not expired and now this month once again, auto pay did not go through. I've been waiting to chat with a rep for 15 minutes, do not have time to sit on a phone. Very frustrating.

Posted by
Admin1

Message 4 of 7
480 Views

Hi vincenthogan -- Each time you enter AutoPay information there is a 30-45 processing period before it starts deducting from your account. Typically it starts pulling after 1-2 billing cycles. You'll know that AutoPay is in effect when your bill states Credit Card Payment To Be Applied (insert due date).




Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 5 of 7
446 Views
Visitor
Member Since: ‎02-13-2017
Posts: 0
 
(0 Views)
Re: auto pay not working and gave me late fees
[ New ]
 

I have had to call customer service more than once to deal with this issue.  After the first call when the Comcast agent said he couldn't figure out why the autopay wasn't working, he reactivated the autopay feature and made sure the credit card was entered properly.  Then he indicated that my payment would process appropriately in the next week. I also noted in the payment/billing activity that a payment would be processed on 2/12/17, but on 2/13/17 my service was shut off unexpectedly because the automatic payment did not process.  What's more, is that I never received an email notifcation indicating that the automatic payment did not process (even though I am signed up for these types of account notifications) or that service was being shut off until my husband who works from home was in the middle of a webex conference for work and the internet stopped working.  TOTALLY UNACCEPTABLE.  The agent I spoke with apolgized for the issues and credited back the reactivation fee and late fees, which is great, but as a continuing customer, how am I supposed trust that this will not happen again when it has now happened 2x in a matter of months.  For such a large company, this type of a technology issue is completely insane to me.  What is the root cause for these errors?  How are you dealing with this customer service issue?  What are you doing to correct it?  As a paying customer, I would like to know. 

 
 
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 6 of 7
306 Views

It has been over 45 days and once again, auto pay is not working.

Posted by
Admin1

Message 7 of 7
286 Views

vincenthogan -- I reviewed your account and your account history shows you setup AutoPay on 4/24. That would not allow enough time for that AutoPay information to pull a payment out for your most recently due bill. This AutoPay is set to pull your next due payment and all future due payments. Please remember that when you enter AutoPay information it takes 1-2 billing cycles before AutoPay starts pulling payments. 




Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon