Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,666,382

members

67

online now

1,837,834

discussions

Back to Top

Letter from Comcast advises that I will be charged $10 monthly for Xfinity modem I do not have

SOLVED
Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 1 of 4
253 Views

Been waiting for Chat to connect for 45 minutes.

Happily the letter said they will not charge me for the modem I do not have retroactively.

3 REPLIES
Posted by
Problem Solver

Message 2 of 4
229 Views
Solution

Well, that's positively decent of them.  Comcast does this a lot, unfortunately.  It's happened to many of us here who own our own equipment. Comcast knows you don't rent. Perhaps one of the employees here may help;  otherwise, <Edited for violating forum guidelines: "Soliciting">

Posted by
Official Employee

Message 3 of 4
166 Views

Hello davidanders. I can assist with your modem charge concern. I'll need to access your account to research this. Please send me a private message and include your full name, service address, and account number so I can take a look. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Highlighted
Posted by
Service Expert

Message 4 of 4
126 Views

Your post was removed to a secure, inaccessible location for a violation of Forum Guidelines [off topic]. If you are not familiar with our Guidelines you may review them here.