Welcome to Comcast Help & Support Forums
You can contribute an answer or post a question.
Reply
Posted by
New Visitor
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.
Member Since: ‎07-26-2011
Posts: 3

Why does the internet go off and on; why does everything take so long to download?

I have Comcast internet and the signal goes off and on.  And downloading speed is incredibly slow. 

Please fix it.

Posted by
Silver Problem Solver
Member Since: ‎06-17-2008
Posts: 13,999

Re: Why does the internet go off and on; why does everything take so long to download

please call 1800 comast

Posted by
Email Expert
Member Since: ‎05-21-2006
Posts: 29,241

Re: Why does the internet go off and on; why does everything take so long to download

Posting in the Forums does not mean you are talking to anyone in Comcast that can fix your problems.  We are customers just like you, that volunteer time here trying to help fellow customers. 

You need to call 1-800 comcast and have a Tech come out.  OR- You can post the problems you are having in detail here, and someone will try to help you- if it can be done without a Tech coming to your home.  But you need to give some specific details for anyone to help in the Forums. 



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Posted by
Connection Expert
Member Since: ‎12-24-2003
Posts: 47,308

Re: Why does the internet go off and on; why does everything take so long to download

Guess rog is bored although I don't see how that's possible....

 

 

OP, wanna' start here;

 

http://forums.comcast.net/comcastsupport/board/message?board.id=5&message.id=69354&jump=true

http://forums.comcast.net/comcastsupport/board/message?board.id=5&message.id=69355&jump=true


Try the self troubleshooting stuff, then post the requested stuff please.