Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,724,899

members

69

online now

1,886,938

discussions

Back to Top

Parental Controls NOT working

Posted by
New Poster
  • Congrats on Posting your first topic!

Message 1 of 2
1,683 Views

So far, the parental controls on our SMCD3GNV WIFI gateway/router are not working.   There are no error messages.... it just simply isn't working.   

The directions outlined in http://customer.xfinity.com/help-and-support/internet/set-up-parental-controls-with-comcast-networki... were followed.    As a test I tried blocking urbandictionary.com to one of the "untrusted" devices (which happens to be an ipad).  I confirmed that the device I listed as untrusted was indeed the device I was using (via MAC address and IP address).... and still it isn't working.

 

Since the Comcast devices are running "crippled" firmware, there doesn't seem to be many different things to try.   And since it is crippled firmware, I'm unable to change the gateway's DNS settings so I'm stuck with parental controls that don't work... at all.   Any ideas?

1 REPLY
Posted by
Frequent Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congratulations, you've have started 5 topics! Your communication brings an abundance of information to the community!
  • Congrats on Posting your first topic!

Message 2 of 2
733 Views

My router is doing the same.  I have the Arris DPC3941T.  The parental controls did work for about a week and then they went out and numerous calls to tech support did not resolve the issue.

Today I called for the last time and I am just going to purchase my own router where i can use my dns static address for securities.