Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,638,750

members

30

online now

1,816,297

discussions

Back to Top

Log in Securely to xfinity, flips over to unsecured page

Posted by
Frequent Visitor

Message 1 of 2
724 Views

I use Norton Security 360 to log into online accounts, and, in addition to good old "Hello Guest" who is alive an well (but evil), now, when I login to a secure site, I am redirected to an unsecured site. It has an https:// preface, but it is not secure. I've checked out some of the page sources, and there is a lot of odd conversation.  I have not heard any ideas from the local xfinity/Comcast office. They are just salespeople. I called the "General and Advanced Security Assurance" number, given to me by Comcast, and they seemed not to know anything about this long standing issue. I sent several screen shots today, but they the security department seemed disinterested.

 

I'm wondering if the only solution is the scrap everything and start over with a new account number, but I sure haven't gotten any direction from Comcast. The last 8 months with "Hello Guest" and "Hi, Guest" have caused malfunction junction.  Some days, I cannot do anything securely on the Comcast site. I've been using G-Mail, but I am paying for full service at Comcast. I should be able to login and watch tv...or read email. I don't want to risk passing along a bug to any of my contacts. After all this time, it is disturbing not to have any support from the Comcast folks. 

 

 

1 REPLY
Posted by
Regular Contributor

Message 2 of 2
538 Views

Hi. Your message has had close to 200 views but no one has bothered to reply in the two weeks since you posted it. It's no wonder. It makes no sense. Why are you using Norton 360 secure login if it isn't working? Sounds like a waste of money.

 

You don't mention your OS or what browser you're using. Your whole message is just a mixed up mess. Have you tried logging into your Xfinity account on another device? How about using a different browser? Have you tried temporarily disabling Norton 360 and then logging into your Xfinity account? 

 

I am using Chrome with "HTTPS Everywhere" installed and my connection is secure:  xfinity.JPG

 

https://www.eff.org/Https-Everywhere

 

Ensure you're attempting to log into the correct website. If you are truly being redirected, you might also consider the possibility that your machine is compromised with malware. You might want to have it examined. You can get free expert help to check for and remove any malware that exists. My instructions: https://forums.xfinity.com/t5/Anti-Virus-Software-Internet/random-survey/m-p/2856523#M107283



<--> U.S. Navy Vietnam Era veteran. You're welcome. <-->