Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,728,094

members

10

online now

1,889,836

discussions

Back to Top

Free McAfee for Comcast subscribers?

Posted by
Frequent Visitor

Message 1 of 12
4,957 Views

After seeing the too good to be true deal for free virus protection I installed McAfee on October 12th.

Now it says on December 5th I must pay for a new subscription? Why did Comcast fail to tell us this up front. It is not mentioned anywhere during the install process or on the comcast web site or the commercial. This is a let down and false advertising!

11 REPLIES
Posted by
Contributor

Message 2 of 12
4,947 Views
You have to update the serial every other year I think...
Posted by
Valued Contributor

Message 3 of 12
4,946 Views

Welcome to the Forums!  You do not have to pay for the Comcast version of McAfee.  Did you go to the Comcast.net Security page  to download your version?  Read through the Help With McAfee Security Suite to see if anything might help you.  Did you read the Before You Install area?  Which browser are you using?

 

 

What other AV program was installed previously and how did you remove it?  Wondering if you had the pay version of McAfee before installing the Comcast one.

 

Moms...

Posted by
Frequent Visitor

Message 4 of 12
4,910 Views
I had Norton's I do not recall ever having McAfee on here before. Does anyone else have a similar problem?
Posted by
Bronze Problem Solver

Message 5 of 12
4,898 Views

As moms mentioned, did you download it from the Comcast security website? By doing so you register your Comcast address as part of the process which in turn gets you the free copy.

 

There is no bate and switch here, this is free software worth around $120 which you get as a result of being a Comcast customer.

Posted by
Frequent Visitor

Message 6 of 12
4,865 Views

Yes I installed it from the Comcast web site. Last night I was told to remove it with the McAfee removal Toll and re-install it. I was told that it will always come up one year after installation telling you to re-subscribe. Comcast told me to uninstall it then re-install it so as not to have to pay McAfee for a subscription. They said there is no way around this and it is happening to a lot of people. For some reason it wanted a re-subscription after only 1.5 months. I hope it waits a year this time.

 

 

Posted by
Valued Contributor

Message 7 of 12
4,850 Views

Gunner...I noticed you replied on another thread saying users have to resubscribe a short time after initial install.  I used McAfee for a long time and have switched to another program but usually your issue does not happen.  I'm surprised you had a tech tell you it happens alot.  One thing I'd like you to confirm since you said you had Norton before.  Did you use their removal tool after removing their program?  Also...when you open the McAfee Security Center does it say Comcast McAfee?  You should see the logo.  Also you might just click through a few of the Help With McAfee Security Suite links to see if anything was missed. 

 

Here is the page that is recommended to check for more help: Free Technical Support  Try the Free Chat!

 

Moms...

 

 

Posted by
Service Expert

Message 8 of 12
4,771 Views

I have been using McAfee since 02/07, and I have never been told that I have to pay, or do a reinstall or any type of "annual" pay/reinstall/or whatever!

 

And Moms, do you remember the post about the OP complaining about McAfee updating all of the time? Well, since then, besided the updates I get in the AM, I am also getting a set updates about every other night around this time. Just thought you like to know.

see ya

sem

 

SI VIS PACEM PARA BELLUM

Photobucket



Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Valued Contributor

Message 9 of 12
4,758 Views
Interesting...they must of changed something since I've switched to Avast. 
Posted by
Bronze Problem Solver

Message 10 of 12
4,696 Views
I don't think it's accurate that you need to remove and re-install. It's licensed to you and that should just keep going all the time you have your comcast.net address.
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 11 of 12
4,656 Views
Mcafee is horrible. I have been trying to download the security suite for over 8 hours. The message says I am not connected to the internet despite the fact that I am. The Mcafee people can not speak clearly and do not understand english. I have gone through the everything under the sun with them dozens of times. First they say that Mcafee can not operate with wireless router. I hook up directly. they say that comcast is too slow. The ping test shoiwed 15 milliseconds, then they want money to diagnose problem, then  they say they dont know why it won't download. I have drained the batteries on 3 phones today. Still no help from Mcafee or Comcast. Now Mcafee says to call Comcast....Comcast says to call Mcafee so I am at a standstill. I was happy with comcast untill these issues with Mcafee. they seem to disavow anything to do with Mcafee as it is not their responsibility. however they advertize that it is included with the subscription. No one seems to care that it is not available.
Posted by
Bronze Problem Solver

Message 12 of 12
4,621 Views
What URL are you trying to install it from?